Installing kibana on linux


(Aviral Srivastava) #1

I am trying to install kibana 5.1 on Red Hat Enterprise Linux Server release 7.2
following the link :-https://www.elastic.co/guide/en/kibana/current/rpm.html

For installing kibana: - sudo yum install kibana
I get below error:-
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

/lib64/libcurl.so.4: undefined symbol: libssh2_scp_recv2

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.7.5 (default, Aug 29 2016, 10:12:21)
[GCC 4.8.5 20150623 (Red Hat 4.8.5-4)]

If you cannot solve this problem yourself, please go to
the yum faq at:
http://yum.baseurl.org/wiki/Faq

Using below command for installing elasticsearch worked earlier:-
sudo yum install elasticsearch


(Tim Sullivan) #2

The error message shows that the problem happened with the yum command on your system, not with the Kibana package itself. As you say, you were able to install Elasticsearch fine using the same procedure, but just a few wild guesses

  • Did you do any system upgrades in between the time you installed Elasticsearch and tried to install Kibana?
  • Did you try installing another version of Python on the system after installing Elasticsearch?
  • Does this StackOverflow post help at all http://stackoverflow.com/questions/23589971/yum-not-working

Since it is a yum problem and not an Elastic problem, you might want to look for tips in that FAQ link in the error message (especially FAQ #7) or reach out to the yum / Red Hat community for guidance


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.