Installing shield in kibana - getting error for plugin command


(vp) #1

I want to implement shield and watcher in my project. When I run the command to install plugin, I am getting error message that plugin command is not supported. What could be the reason. Mine is windows OS.


(Mark Walkom) #2

What command?
What error?
What versions?


(vp) #3
  1. First I ran curl -u es_admin -XPOST "http://localhost:9200/_shield/user/rashmy"-d "{"password" : "password", "roles" : [ "rashmy"]}"

I got below error

{"error":{"root_cause":[{"type":"invalid_index_name_exception","reason":"Invalid
index name [shield], must not start with '', '-', or '+'","index_uuid":"na"
,"index":"_shield"}],"type":"invalid_index_name_exception","reason":"Invalid ind
ex name [shield], must not start with '', '-', or '+'","index_uuid":"na","in
dex":"_shield"},"status":400}curl: (3) [globbing] nested brace in column 31

I am using kibana-5.0.2-windows-x86 version


(Mark Walkom) #4

There's no indication that you have installed Shield here.


(Reuben L ) #5

Have you installed x-pack?


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.