Issue installing x-pack with logstash 5.2.1


I installed logstash 5.2.1 & tried offline installation of x-pack 5.2.1. This seems to hang, with no progress on installation. file was downloaded and placed in /var/tmp folder.

ls -lrt /var/tmp/

-rwxrwxrwx 1 root root 124956667 Feb 20 10:42 /var/tmp/

I tried installing this x-pack using 'logstash-plugin' command. It hangs and does nothing.

DEBUG=1 bin/logstash-plugin install file:///var/tmp/

DEBUG: exec /usr/share/logstash/vendor/jruby/bin/jruby /usr/share/logstash/lib/pluginmanager/main.rb install file:///var/tmp/
Local file: /var/tmp/
Installing with strategy: LogStash::PluginManager::PackInstaller::Local
Installing file: /var/tmp/

Nothing happens after this. There plugin does not get installed nor does it fail.
However, the same xpack plugin file gets successfully installed to Elasticseach and Kibana. Plugin installation hangs ONLY for logstash.
I don't understand what the problem is. Can someone help me fix this ??

Is your Logstash on the same machine as your ES? If not, can you download Logstash on the same machine as your ES and give the install a try.

You can also run jstack on the Logstash process to see what's going on with the thread.

Thanks @jkuang !
It seems to work fine. I tried on a system with & without ES. Works on both.
However, it take way loooong time to complete. Though installation happens, the SSH session hangs and terminal becomes unresponsive. I see this while executing 'logstash-plugin' and 'kibana-plugin' commands. With 'elasticsearch-plugin' command things are seamless.

The logstash x-pack installation should also work seamlessly. What is the hardware specs on the machines you're trying to install logtash on? What other applications / processes are you running those machines?

I also had similar issue before. I used to receive segmentation fault error after a very long time during xpack installation. Link to the issue here. This might help

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.