Kibana 4.2.0 Plugin OFFLINE installation?


(Thorsten Nickel) #1

Hello,

is there a possibility to have the plugin installed from the local file ?
I tried a syntax similar to the elasticsearch plugin installation, where I can do it offline, as long as i can provide the file.

Examples:
bash-4.2$ ./bin/kibana plugin --install file:///tmp/sense-2.0.0-beta1.tar.gz
Invalid install option. Please use the format //.

bash-4.2$ ./bin/kibana plugin --install elastic/sense -u file:///tmp/sense-2.0.0-beta1.tar.gz
Invalid install option. When providing a url, please use the format .

Any other possibilities ?

Kind regards,
Thorsten


(Thorsten Nickel) #2

Now I found how to manage this, maybe this helps other users as well.

Use this format:

./bin/kibana plugin --install sense -u file:///tmp/sense-2.0.0-beta1.tar.gz

Kind regards,
Thorsten


(Mark Walkom) #3

We mention the use of file here :slight_smile:


(Thorsten Nickel) #4

Hi Mark,

the use of the file-syntax was not really the problem, more exactly it was the path used as the install option.

From the helptext:

-i, --install <org>/<plugin>/<version>  The plugin to install

Key is, when using the file:/// syntax, I needed to strip out out all the 'path' for the install parameter, only leaving 'sense' or 'license' or 'marvel'

All examples in the docs do not mention this:

Installing Plugins
Use the following command to install a plugin:

bin/kibana plugin --install <org>/<package>/<version>

You can also use -i instead of --install, as in the following example:

bin/kibana plugin -i elasticsearch/marvel-ui/latest  

Or:

bin/kibana plugin --install github-user/sample-plugin

Hope this helps,
Thorsten


(Mark Walkom) #5

Fair point, will see if we can get that elaborated on a bit more.


(Garrett Johnson) #6

On Windows systems I am unable to get any combo of offline url to work.

For instance

kibana plugin --install marvel --url file::///c:/users/downloads/My Name/marvel-2.2.0.tar.gz
kibana plugin --install marvel --url file:://c:/users/downloads/My Name/marvel-2.2.0.tar.gz
kibana plugin --install marvel -u - file:://c:/users/downloads/My Name/marvel-2.2.0.tar.gz

Plugin installation was unsuccessful due to error "No valid url specified"

I've tried tons of combos with case adjust etc.

Would be helpful if there was a spelled out example for a specific username and path on windows and linux systems.


(Garrett Johnson) #7

I worked around this by eventually copying marvel-2.2.0.tar.gz to the kibana bin folder and running

kibana plugin -i marvel -u file:marvel-2.2.0.tar.gz


(Learningloop) #8

Thank you for the workaround. Installed sense by copying the tar file to bin folder of kibana and using your format.


(Fotis Gimian) #9

This solution worked for me, thanks heaps :slight_smile:


(system) #10