Kibana 5.0 Alpha 3 Security Settings


(Kennedy Kan) #1

I have set up some roles and users in the security page.


But it turns out that nothing can be seen when I logged in as Ray_Wong

What is wrong with that?


(Tim Sullivan) #2

Hi Kennedy,

You'll need to create a kibana_user role and give the users that role so they can use Kibana. The role will need the manage, read, index permissions on the .kibana* indices. You can assign as many roles to your Kibana users as you need, so you can assign other roles that give permission over your data indices.

Note that this will be made easier in alpha4, which will provide a default kibana_user role for you.


(Tim Sullivan) #3

Couple more things:

  • If you want your Kibana users to be able to create visualizations, they will also need the write permission on the .kibana* indices.
  • The role just needs read and view_index_metadata permission on the indices in order to access them in Kibana. Looks like you have read and manage

(Kennedy Kan) #4

Thank you
That helps a lot. But one more point for me to concern is that, if I didnt grant rights for a user to create or delete an index, he can only be stopped from doing that in console page. But how can I also block the user from deleting or creating existing one in the indices page of settings.
Also, if the user create a new index through logstash how am I able to detect the user who create it?


(system) #5