Kibana 6.3: Connecting data points in TimeSeries in 'Visual Builder'


(MS) #1

Hi,

I am creating some time series plots in Visual Builder. The data points are connected when the x-axis time unit is large; but as I zoom in (finer resolution in x-axis), I only see the dots.

1

2

3

Is there a way to keep the data points connected across all resolutions?

Thanks,

Shafique


(Bhavya R M) #2

Hi,

I tried this in my local and my chart looks like yours.
@simianhacker is this possible right now?

Thanks,
Bhavya


(Chris Cowan) #3

The issue here is that you've zoomed past the resolution of your data. There is a setting under Panel Options that allows you to change the interval. If you use the >= and then the minimum resolution the data should be viewed as then you won't have this issue. For example, if I had event data that was collected and shipped every 10 seconds then I would set the interval to >=10s. Which means use auto bucketing for everything greater or equal to 10s.

As for "just" connecting the dots... the issue with that is outlined in https://github.com/elastic/kibana/issues/11793 and https://github.com/elastic/elasticsearch/issues/24747


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.