Kibana Dashboard by default not fetching data from elastic with given hyper link


(Guru Swamy) #1

I have created summary dashboard, in that I have embedded with sub dashboard hyper link, when I select it or click on the link, it is not fetching data, I have to explicitly refresh it using play button or else have to change refresh interval.
Kindly address this issue, if any one aware on this.


#2

Hi @Guru_swamy,

Could you please let me know what Kibana version you use and how exactly you embedded with sub dashboard hyper link? Did you use Link-via-Markdown like described here or what?

Thanks,
Oleg


(Guru Swamy) #3

Kibana version is 6.2.1
I have embedded sub dashboard link in visualization(Data table).
Sub dashboard fetches data from saved search(created from Discover).
Saved search points to index.


#4

Sorry, I'm not sure I totally understand what Data table you mean? As far as I can tell you can't display links in Data table visualization. Can you clarify what this Data table is exactly?


(Guru Swamy) #5

Data Table is as below
Visualization-> Data(Data Table) brings data from index.
I have created hyper link script filed which is being used by visualization.
Hyper link script field contains the dashboard link <-this dashboard is from saved search <-Saved search is from elastic index.

Even in normal dashboard's which are created from saved search does not fetches data by default when we click on the dashboard link.
We need to wait till the next refresh cycle or else have to use play button.

Expectation is, when we click on dashboard link, should fetch data.

Please suggest.


#6

Okay, I can't reproduce this, so let's try to clarify what issue exactly you have:

  • When you say does not fetches data, what exactly do you mean? No data displayed at all? Data is outdated?
  • When you click on the link and new dashboard is loaded you should see request(s) in the browser dev tools (network panel), do you see them? Can you save them into HAR and share (let me know if you need help with that)?
  • Do you see any errors or warnings in the browser console?

The more details you can provide, the better. It would be great if you can make screenshots or even record an animated gif/video (with browser tools open).


(Guru Swamy) #7

Please find reply in inline as below.
When you say does not fetches data, what exactly do you mean? No data displayed at all? Data is outdated?
Ans: yes, No data displayed when I submit and copy past the dashboard link on the browser, but when I click on the play button, it fetches data.

When you click on the link and new dashboard is loaded you should see request(s) in the browser dev tools (network panel), do you see them? Can you save them into HAR and share (let me know if you need help with that)?
Ans: yes, I could see network request using dev tools and have the below error.

TypeError: $scope.searchSource.onError is not a function
at kibana.bundle.js?v=16573:64
at kibana.bundle.js?v=16573:64
at Scope.$digest (vendors.bundle.js?v=16573:65)
at Scope.$apply (vendors.bundle.js?v=16573:65)
at done (vendors.bundle.js?v=16573:65)
at completeRequest (vendors.bundle.js?v=16573:65)
at XMLHttpRequest.xhr.onload (vendors.bundle.js?v=16573:65)

Do you see any errors or warnings in the browser console?
Ans: Error details provided.

Thanks.


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.