Kibana displaying a BLANK page


(Sameer Panicker) #1

I was able to run Kibana properly. But I went a step ahead and tried making it a HTTPS. I followed the steps mentioned in below link.
https://www.ulyaoth.net/resources/tutorial-install-logstash-and-kibana-on-a-windows-server.34/

So, now Kibana is loaded under IIS and I am able to load it on the browser. But nothing is displayed under the tabs. It BLANK.

Kibana is now setup on 5602 port.

Error on running the command line -

What setting I am missing here?


(Tyler Smalley) #2

The error your getting on the command line means that something else is running on that port.

The tutorial you referenced has ISS running on port 80 with a reverse proxy to Kibana on it's default port of 5601. What is supposed to be running on port 5602? Kibana or the proxy?


(Sameer Panicker) #3

As per the link, i started setting http on 80 port. That worked fine. Since i had to make my kibana link secured, https i added a new binding with 5602 port as 5601 is the default one which kibana already uses.


(Tyler Smalley) #4

Since you previously had it working on port 80, what about having Kibana provide the SSL? There are details here: https://www.elastic.co/guide/en/kibana/current/production.html#enabling-ssl


(Sameer Panicker) #5

I have created a PFX certificate protected with a password.

I have placed it under C:\kibana-4.4.1-windows\kibana-4.4.1-windows\certs path.

SSL for outgoing requests from the Kibana Server (PEM formatted)

server.ssl.key: /path/to/your/server.key ???
server.ssl.cert: /path/to/your/server.crt

What should be the value for the key here ?


(Sameer Panicker) #6

I created a KEY and CRT file using OpenSSL. Now, I moved ahead and got another issue.

Is there a way to skip or provide the PEM password ?


(system) #7