Kibana i18n plugin not replacing some texts

Hi
I have translated Kibana and created a plugin for that.
Everything is good and the plugin is loading, I just see some texts are not replaced although the translation for those texts exist.
I mean most of texts are replaced but some are not, and I don't see any errors in log files.
I am using ELK 7.0.0.

Problem solved but not in the right way!
I moved and renamed the TRANSLATION_FILE.json to KIBANA_INSTALLATION_PATH/node_modules/x-pack/plugins/translations/translations/zh-CN.json
and change the i18n.locacle to zh-CN and all texts replaced without any problem.
So I guess there is a bug.
For now it is enough for me but let me know if you solved the problem.

the translations are part of each plugin, hence why you had only a part of Kibana translated. If you want to do the translations by yourself, you can grep for all zh-CN.json files and translate all of them.
zh-CN is the first official translation that Kibana implemented so it should be the most complete.

Did I tell I had translated just some parts?
I replaced mt file with zh-CN.json in KIBANA_INSTALLATION_PATH/node_modules/x-pack/plugins/translations/translations/ and my kibana is now fully translated.
But when I am doing it via my plugin, it does not.