Kibana in not running after setting log file destination

I set the path to log file in kibana.yml file after that kibana is stop working.
This is kibana.yml file:

# Kibana is served by a back end server. This setting specifies the port to use.
server.port: 5601
# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
server.host:"10.128.0.26"
# Enables you to specify a path to mount Kibana at if you are running behind a proxy.
# Use the `server.rewriteBasePath` setting to tell Kibana if it should remove the basePath
# from requests it receives, and to prevent a deprecation warning at startup.
# This setting cannot end in a slash.
#server.basePath: ""
# Specifies whether Kibana should rewrite requests that are prefixed with
# `server.basePath` or require that they are rewritten by your reverse proxy.
# This setting was effectively always `false` before Kibana 6.3 and will
# default to `true` starting in Kibana 7.0.
#server.rewriteBasePath: false
# The maximum payload size in bytes for incoming server requests.
#server.maxPayloadBytes: 1048576
# The Kibana server's name.  This is used for display purposes.
server.name: "Kibana"
# The URLs of the Elasticsearch instances to use for all your queries.
elasticsearch.hosts: ["http://10.128.0.26:9200"]
# When this setting's value is true Kibana uses the hostname specified in the server.host
# setting. When the value of this setting is false, Kibana uses the hostname of the host
# that connects to this Kibana instance.
elasticsearch.preserveHost: true
# Kibana uses an index in Elasticsearch to store saved searches, visualizations and
# dashboards. Kibana creates a new index if the index doesn't already exist.
kibana.index: ".kibana"
logging.dest: /var/log/kibana/kibana.log
# Set the value of this setting to true to suppress all logging output.
#logging.silent: false
# Set the value of this setting to true to suppress all logging output other than error messages.
#logging.quiet: false
# Set the value of this setting to true to log all events, including system usage information
# and all requests.
logging.verbose: false

this is what i get after running
service kibana status

root@elastic-stage-vyakar:/var/log# service kibana status
● kibana.service - Kibana
   Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Fri 2019-08-09 08:13:12 UTC; 1h 17min ago
  Process: 4570 ExecStart=/usr/share/kibana/bin/kibana -c /etc/kibana/kibana.yml (code=exited, status=1/FAILURE)
 Main PID: 4570 (code=exited, status=1/FAILURE)
Aug 09 08:13:11 elastic-stage-vyakar systemd[1]: kibana.service: Main process exited, code=exited, status=1/FAILURE
Aug 09 08:13:11 elastic-stage-vyakar systemd[1]: kibana.service: Failed with result 'exit-code'.
Aug 09 08:13:12 elastic-stage-vyakar systemd[1]: kibana.service: Service hold-off time over, scheduling restart.
Aug 09 08:13:12 elastic-stage-vyakar systemd[1]: kibana.service: Scheduled restart job, restart counter is at 3.
Aug 09 08:13:12 elastic-stage-vyakar systemd[1]: Stopped Kibana.
Aug 09 08:13:12 elastic-stage-vyakar systemd[1]: kibana.service: Start request repeated too quickly.
Aug 09 08:13:12 elastic-stage-vyakar systemd[1]: kibana.service: Failed with result 'exit-code'.
Aug 09 08:13:12 elastic-stage-vyakar systemd[1]: Failed to start Kibana.

however i can get log details by using journalctl -u kibana.service but i want it in file format.
this is log:

Aug 09 09:36:39 elastic-stage-vyakar systemd[1]: kibana.service: Main process exited, code=exited, status=1/FAILURE
Aug 09 09:36:39 elastic-stage-vyakar systemd[1]: kibana.service: Failed with result 'exit-code'.
Aug 09 09:36:40 elastic-stage-vyakar systemd[1]: kibana.service: Service hold-off time over, scheduling restart.
Aug 09 09:36:40 elastic-stage-vyakar systemd[1]: kibana.service: Scheduled restart job, restart counter is at 3.
Aug 09 09:36:40 elastic-stage-vyakar systemd[1]: Stopped Kibana.
Aug 09 09:36:40 elastic-stage-vyakar systemd[1]: kibana.service: Start request repeated too quickly.
Aug 09 09:36:40 elastic-stage-vyakar systemd[1]: kibana.service: Failed with result 'exit-code'.
Aug 09 09:36:40 elastic-stage-vyakar systemd[1]: Failed to start Kibana.

Any help, anything that i should add or change ?
Thanks

Hi @Ayush_Verma,

First of all can you can confirm that Kibana starts if you just comment out logging.dest: /var/log/kibana/kibana.log in your current config? If yes, than try to set this setting to path that Kibana can definitely access, e.g. somewhere in your home directory and in a folder that definitely exists.

Best,
Oleg

Yes, i set the path to /etc/kibana/kibana.log and give the write access now its working.