.Kibana Index from Version 4.6 is not working in Kibana 5.2

@warkolm I migrated my cluster fro ES 2.4 and Kibana 4.6 to ES & Kibana 5.2.
I recreated all the indexes and restored the data exactly as it was in ES-2.4 and restored the data.

I did setup the Kibana 5.2 as well, it is talking to my new ES 5.2 instance.
All my indexes with data are appearing in the discover tab. I also restored the .kibana index with searches, Visualizations and Dashboards.
They are all showing up in the new Kibana 5.2.
But when i try to open a Visualization it complains.

There is a problem with this saved object The saved search associated with this object no longer exists. If you know what this error means, go ahead and fix it — otherwise click the delete button above.

I am sure i have the "search"available and loaded in Kibana. But the Visualization is unable to locate the searchid.

Could not locate that search (id: xxxxxyyyy)

I tried, tried and tried, NONE of the searches restored from the .Kibana Index work in the Kibana 5.2.
Even i tried saving the search in a new name and edited the Visualization to reflect the new search name..
But,, again. the visualization is unable to locate the search//

Keeps throwing the same error over and over again. I restarted the Kibana instance, cleared the browser cache.. etc., nothing works.
This seems to be a bug in version 5.


The savedSearchId column in the Kibana 4.6 Visualization stores it as plain text, where as in Kibana 5.x savedSearchId is a random generated number because of which the Visualization is unable to locate that search

Can someone review this please?

Confirming, I opened https://github.com/elastic/kibana/issues/10732.

Thank You

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.