Kibana: Kibana's memory limit won't change. Even to default

Hi,

I'm just upgraded Kibana to 7.12. And I noticed Kibana's memory limit configured at 4GB according to Stack Monitoring.

So then I set the memory limit to 2GB, it was a success. Sometime later, due to web server limitation, I changed Kibana's listen port to 80 and 443 to access Kibana directly without a web server and enabled these configurations to allow Kibana to listen on lower port number:

setcap cap_net_bind_service=+epi /usr/share/kibana/bin/kibana
setcap cap_net_bind_service=+epi /usr/share/kibana/bin/kibana-plugin
setcap cap_net_bind_service=+epi /usr/share/kibana/bin/kibana-keystore
setcap cap_net_bind_service=+epi /usr/share/kibana/bin/kibana-encryption-keys
setcap cap_net_bind_service=+epi /usr/share/kibana/node/bin/node

Then I noticed Kibana's memory limit changed to 4GB again ignored my configuration. I have tried to change the memory limit in:

/etc/sysconfig/kibana
/etc/kibana/node.options

Even forcing in:

/usr/share/kibana/bin/kibana
/etc/systemd/system/kibana.service

None of them was working. Kibana memory limit still configured at 4GB.
I also tried to delete the memory limit configuration "--max-old-space-size=2048", but still not working.
According to this guidance, Kibana's default memory limit at 1.4GB.

Any suggestion or solution for this issue?

Regards,
Ade

Anyone can help my problem? Thank you!

@jbudz - can you plz help when you get a chance,

Thanks

Hey Ade,

Can you share the permissions set for /etc/kibana/node.options? I'm wondering if the file isn't readable by the kibana user.

Hi @jbudz ,

Thanks for the respond. Here's the permissions:
kibana

Any clue? permissions seems correct.

Hi @jbudz,

I think I found a temporary solution to my problem. All I need to do is to add the memory limit configuration "--max-old-space-size=2048" in:

/usr/share/kibana/bin/kibana

in this line, like this:

NODE_OPTIONS="--no-warnings --max-http-header-size=65536 --tls-min-v1.0 $KBN_NODE_OPTS NODE_OPTIONS" NODE_ENV=production exec "{NODE}" --max-old-space-size=2048 "{DIR}/src/cli/dist" {@}

and here's the result:
kibs

but I think this is not standard to set Kibana's memory limit. Any thought?

hmm.. Anyone?