Kibana plugin compatibility issue

We are developing plugin for kibana. It is well known, that we need to use the dev version of kibana. Now it is 7.0 (as for K, as for Ela). One time we had get errors, since the HAPI version had been upgraded to 17.
But the current release of kibana - 6.5.4 and it is used previous version of HAPI. So the plugins, that are developed with current dev-version of kibana ARE INCOMPATIBLE with previous version of kibana!!!
What you can recommend to do for providing compatibility with previous version of kibana?


I'll check with the dev(s) who performed this upgrade to see if they have any tips. Will follow up shortly!


Okay, I've spoken with the dev who performed the upgrade. He had the following to say:

There's not a compatibility layer way of making this work with both new and old versions of Hapi unfortunately (and believe me I tried to make one).

Your best bet will be to develop a plugin version using the Kibana 6.5 branch with the old version of hapi, but plan on having a different plugin version for Kibana versions 6.6+. The new version of hapi will be included in 6.6 when it's released.

I hope that helps!


Aaron, thank you for your response.
I want to notice one more thing, that can lead to incompatibilty. ES v7-alpha and ES v7 have different response on query in the block of returning total count/hits.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.