Kibana shows browser compatibity issue

My kibana is running on ubuntu box and properly configured the kibana.yml, but when i browse the UI, it shows your browser does not meet the security requirements for kibana
My browser is already latest version. Can someone help to fix this.

Regards,
Dhamodharan

What browser and version are you using?

Browser support documentation

I am using chrome latest version, Version 88.0.4324.150

Any support on this??

You might want to open an issue with the Kibana team.