Kibana still showing indices which have been deleted


(Zac Esa) #1

I deleted some indices and when I do curl 'localhost:9200/_cat/indices?v', the indices are not showing but, in the Kibana Management Dashboard, it's still showing the indexes. See below for screenshots.

I have already tried to remove the index pattern and re-adding it but, it doesn't disappear. I've also tried to delete the whole .kibana index but, still the same. Weird thing is, even though it's showing that one of the index is using up 19.6GB, it actually isn't using up that space. I'm guessing there's some stale Kibana data somewhere?


(Zac Esa) #2

I left it alone for awhile, I came back and the indices are no longer showing in Kibana. Strange.


(Christian Dahlqvist) #3

Monitoring periodically records data about the indices so it can show changes over time, so after you have deleted the index, there will still be records in the monitoring index to show as long as the deletion took pace within the time interval indicated by the time picker in the top right corner, which in your case is an hour.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.