Kibana TimeStamp Offset

Hello, I am wondering how Kibana is handling timestamps' timezones when presenting documents in the discover section.
I was under the impression that Kibana would use the browser timezone if none was specified in the field but here is an example of a 1h offset when the timezone is not specified in the timestamp :

Here is how the fields were created for this test :

PUT plop

{
  "acknowledged" : true,
  "shards_acknowledged" : true,
  "index" : "plop"
}

---
PUT plop/_mapping
{
  "properties" :
  {
    "d" :
    {
      "type" : "date"
    }
  }
}

{
  "acknowledged" : true
}


---

PUT plop/_bulk
{ "create": {"_id":1} }
{"d" : "2019-11-12T00:11:33"}
{ "create": {"_id":2} }
{"d" : "2019-11-12T00:11:33+0100"}

>>>

{
  "took" : 56,
  "errors" : false,
  "items" : [
    {
      "create" : {
        "_index" : "plop",
        "_type" : "_doc",
        "_id" : "1",
        "_version" : 1,
        "result" : "created",
        "_shards" : {
          "total" : 2,
          "successful" : 2,
          "failed" : 0
        },
        "_seq_no" : 0,
        "_primary_term" : 1,
        "status" : 201
      }
    },
    {
      "create" : {
        "_index" : "plop",
        "_type" : "_doc",
        "_id" : "2",
        "_version" : 1,
        "result" : "created",
        "_shards" : {
          "total" : 2,
          "successful" : 2,
          "failed" : 0
        },
        "_seq_no" : 1,
        "_primary_term" : 1,
        "status" : 201
      }
    }
  ]
}

---

GET plop/_search

>>>

{
  "took" : 0,
  "timed_out" : false,
  "_shards" : {
    "total" : 1,
    "successful" : 1,
    "skipped" : 0,
    "failed" : 0
  },
  "hits" : {
    "total" : {
      "value" : 2,
      "relation" : "eq"
    },
    "max_score" : 1.0,
    "hits" : [
      {
        "_index" : "plop",
        "_type" : "_doc",
        "_id" : "1",
        "_score" : 1.0,
        "_source" : {
          "d" : "2019-11-12T00:11:33"
        }
      },
      {
        "_index" : "plop",
        "_type" : "_doc",
        "_id" : "2",
        "_score" : 1.0,
        "_source" : {
          "d" : "2019-11-12T00:11:33+0100"
        }
      }
    ]
  }
}

Here is what is presented in Kibana (with the javascript showing the browser's timezone)

Hello,

You should be able to update the timestamp in Management > Advanced Settings. See this issue for reference.

Regards,
Aaron

Hello and thanks for taking the time to reply.
Sorry that I did not mention that I am aware of this setting that I had tried to modify without luck :

In this instance, what I don't understand is why is Kibana trying to "re-adjust" the time when all the components share the same TimeZone (ElasticSearch, LogStash and Kibana)

What mechanism is trying to adjust the time ?
Is it considering that the field without a timezone is a UTC time ?

Thanks