Kibana web page does not open when virtual machine interface is host-only

I have recently installed elasticsearch on my Kali purple virtual machine with my VM interface setting set as network enabled. I used a vmnet which allowed me access to the internet via my regualr host machine. After initial installation, everything went as expected. I was able to log into the web page, but when I changed the VM setting to host only on my VM, I could not log into the web page. I manually set the IP address in the Kali Network setting to manual and set the IP to match the IP setting in the yml file. I restarted the VM and checked to see if the IP address had taken. It showed the same IP as in my yml file. Whe I tried to restart my kibana service (sudo systemctl restart Kibana), it seemed to initially work, but as soo as I Tried to log into the web page, there was no connection. After checking the status (systemctl status kibana), this had shown a fail in the status. Any suggestions? Thank you.

You need to share your configuration files and any log you have, but it seems to me that this is a network issue and not a Kibana issue.

Thank you. After reinstalling a few times and setting the VM interfaces over along with these actions, it seems to be working right now. Maybe it was just a glitch in the system while working on the elastic setup. There seems to be no issues currently with current configurations.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.