Right now in the actuallyty we are running a Elastic Cluster v 7.5.2 with a Logstash 6.4.2 we want to upgrade our cluster to v 7.9.2 but the only reason we are not able to do this is because in this Logstash server we are running a plugin named: logstash-input-salesforce and if we upgrade this server this plugin is no longer in another version of Logstash.
By any chance anybody here knows where can I get this plugin or get more information about this?

Thank you in advance.

Are you hitting this issue? If so, see the postings in that thread from drivard where he explains how he got it to build and install with later versions.

Negative I don't have any issues, the problem was that I upgrade my current server into a 7.5.2 and I noticed that the logstash-input-salesforce plugin was in there anymore, so I had to return my logstash server to the previous version, fortunately I had a snapshot of the server so it wasn't that much problem to go back to the previous version.
Now i am trying to figure it out a way to upgrade to the latest version of logstash without affecting the salesforce pipeline.

I do not think it is installed by default, so I would not expect it to be there on a new install.

This plugin is not bundled by default, so when you upgrade logstash you need to install it again.

Have you tried to install it by running the command below?

bin/logstash-plugin install logstash-input-salesforce

Thank you leandrojmp that worked like a charm! Really appreciate it.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.