Logstash won't create new index patterns again

Previously, I have connected my logstash with PostgreSQL and Elasticsearch and it also created new index pattern, but it wouldnt load data properly so I deleted my index and restarted logstash to create a new index pattern and that's when problems started. Now I am unable to create a new index pattern.
My logstash.conf file is present in logstash binary folder which looks like this

input {
  jdbc {
    clean_run => true
     jdbc_driver_library => "C:\Users\Hp\Downloads\postgresql-42.3.6.jar"
     jdbc_driver_class => "org.postgresql.Driver"
     jdbc_connection_string => "jdbc:postgresql://localhost:5432/logstas"
     jdbc_user => "postgres"
     jdbc_password => "123456"
     schedule => "* * * * *"
     statement=> "SELECT * FROM logstastable WHERE id > :sql_last_value"
     use_column_value => true
     tracking_column => "id"
output {
 elasticsearch {
  hosts => ["localhost:9200"]
  index => "logstash_index"
   codec => rubydebug

You can create the index pattern in Kibana.

Yes, but when creating new index pattern from kibana it should give me option to create an index pattern whith logstash_index name. just as it happened for the first time when I connected and ran logstash.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.