Migrating plugin from kibana 7.4.2 to 7.12

Hi everyone.
I developed a local plugin to kibana 7.4.2, work and running without any issues.
Currently I am trying to migrate this plugin to kibana 7.12 but there is not enough explanation regarding this subject.

Migrating legacy plugins to the Kibana Platform | Kibana Guide [7.12] | Elastic
I read the documentation above, but it doesn't contain enough practical information.

Here are the steps I made so far:

  • Downloaded the elasticsearch 7.12 zip file, extracted it and ran ./bin/elasticsearch.bat on localhost:9200
  • Cloned the kibana repo and checkout to 7.12 branch, ran the yarn kbn bootstrap and then yarn start command on localhost:5601
  • Both elasticsearch and kibana works locally
  • Then I copied my plugins from the 7.4.2 to the ./kibana directory under the 7.12 kibana branch


  • Those plugins are working fine on kibana 7.4.2 but I can't see them at the kibana visualize library on kibana 7.12
  • I have the correct Node + Yarn versions

Plus, I tried to copy the plugin itself to the kibana 7.12 ./kibana directory, but when I run yarn start the kibana at localhost:5601 doesn't recognize this plugin.

Is there anyone who can help me doing that? Where to begin? I am chasing my tail here.

1 Like

Here is the migration guide and some examples.

Hi Aaron, thank you for your quick response. unfortunately this documentation doesn't contains practical guidelines regarding to how migrating to 7.12 from 7.4.2. It is not cover the subject in details.
Is there any other resource I can rely on?

I don't think you will find a specific guide from that version to another. This guide covers the migration from legacy to the new framework which is something you will need to do since 7.4.2 is considered legacy.

Personally I would probably start migrating your plugin and when you run into specific issues make a new post for each one. Depending on your plugin this could be a lot of work with a lot of changes. Or it could be easy.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.