Migrating the Kibana index

Am upgrading my ELK-stack to 6.0e but get stuck on migrating the .kibana index to the .kibana-6 described here:

My Q is.. how do run create the .kibana-6 index?
Trying to do this in PowerShell.. but am open to other ways.

Running on Windows.
I have tried this:
Invoke-RestMethod -Uri 'http://elasticsearch:9200/.kibana-6/' -Method Put -Body $JSON -ContentType "application/json"
Where the $JSON is the content from the article. Step 2

Get this error:
unknown setting [index.mapping.single_type] please check that any required plugins are installed, or check the breaking changes documentation for removed settings


Worked to upload when i did this:

To perform this migration without downtime, you will need to be running Kibana 5.6. This is the only version which supports both of the index types. If you are running a version prior to 5.6, you will need to omit index.format and index.mapping.single_type from the second step.

Strange, because i am running 5.6.2, and that is not prior till 5.6.

Here is how i did it:


I am unable to reproduce that error on 5.6.2. Can you verify you are re-indexing against 5.6.2, and not 6.0?

Have removed the .kibana index (as the last step in the article).
But maybe the kibana index was not upgraded during my minor upgrades and was in 5.0.

So its not enough to see that i am running kibana in 5.6.2 because the index was maybe not reindexed since the first version i installed which was round 5.5.x

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.