Monitoring from remote cluster with X-Pack Basic license


#1

I have two Elasticsearch clusters PROD (for production) and OPS (for operational), both configured with an X-Pack Basic license. I'm running Elasticsearch version 5.3.0.

I'm trying to configure PROD to report monitoring data to OPS by following the instructions on:
https://www.elastic.co/guide/en/x-pack/current/monitoring-cluster.html

The problem is that OPS is also monitoring itself which causes the monitoring of PROD to be disabled (grayed out in Kibana), because the Basic license only allows monitoring one cluster. How do I go about disabling the OPS cluster monitoring of itself, so I can have it monitor PROD only and stay within Basic license limits?

I tried setting OPS point to a dummy exporter URL in the elasticsearch.yml and restarting:

xpack.monitoring.exporters:
  id1:
    type: http
    host: ["http://example.com:9200"]  # fake host in an attempt to disable local monitoring

The above change seems to cause Elasticsearch not to start at all.

Then I tried disabling X-Pack monitoring and restarting:

xpack.monitoring.enabled: false

The above doesn't seem to have any effect... the PROD cluster is still greyed out in Kibana. Oddly, OPS monitoring of itself still seems to work, even though I expected monitoring to be disabled altogether.

Is there some way to have a PROD cluster report to an OPS cluster with only a Basic license on both?


#2

It looks like disabling the xpack monitoring in the OPS cluster did eventually cause it to stop monitoring itself, and allowed the PROD cluster to light up in Kibana. I'm guessing that I just had to wait a while for the setting to take.


(Jeff Parsons) #3

I ran into the same thing with all 5.4.0 components (two new cluster setups: prod + monitoring).

It would be really nice if Elastic made it more clear in the documentation that a basic-licensed monitoring cluster has to have xpack monitoring disabled in order to monitor another basic-licensed cluster. There's no real errors or information displayed by Kibana to acknowledge there's an issue. Even in the Kibana logging in the monitoring cluster, it does not show an error.

The logstash verbose logging made it seem like all was fine:

  • Detected all clusters in monitoring data have basic license. Checking for supported admin cluster UUID for Kibana <>
  • Found basic license admin cluster UUID for Monitoring UI support: <
    but when I would get into Kibana-> Monitoring, it would just spin and spin without anything useful.

In case it's useful to anyone - I had ran into the following error (only visible via Kibana verbose logging) that clued me into the fact that I had not yet moved from a trial license to a basic license on the new prod cluster:

  • Found some basic license clusters in monitoring data. Only non-basic will be supported

(But this message also made me think I could monitor a local cluster (monitoring) + the remote cluster (production) from the monitoring cluster... but, yeah, no. )


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.