Setting up a Separate Monitoring Cluster (kibana,xpack,es, 2 clusters)[SOLVED]

Hi folks.
I install 2 clusters

first is 2 hosts cluster named kibana for storing and analize monitoring data from prod cluster:
settings a typical:
elasticsearch.yml: : "kibana" : "kibana-0x-0.12x"
http.port: 9200
transport.tcp.port: 9300
http.enabled: true ["", ""]
node.master: true true false


port: 5601 "" false

Now , as I say, I want to use this cluster to monitor production cluster. So I install another 11 VMs, install ES, install XPack and add next to es.yml :slight_smile:

type: http
host: ["",""] false
xpack.monitoring.enabled: true

And, as I expect, my prod cluster appears in Kibana.
But. In monitoring section I have 2 clusters: kibana and my prod cluster, but I cant look to prod cluster because license.
So I have a question - how to disable local cluster monitoring and use it just like a storage for date.

Hi @Oleg.Borisov,

With the basic license, you are limited to monitoring a single cluster (as you noticed). The way to fix this is to simply stop monitoring either of the clusters.

In order to do that, simply disable xpack.monitoring.enabled on the cluster that you do not want to monitor (the "monitoring" cluster, aka the one without xpack.monitoring.exporters defined):

# elasticsearch.yml - Cluster to ignore
xpack.monitoring.enabled: false

This way, that cluster will simply not report its statistics. You cannot disable Monitoring (or the other plugins) dynamically, so this will require the monitoring cluster to be restarted. However, a better way to support this approach is to disable the collection of monitoring data, which you can do dynamically on the monitoring cluster:

PUT /_cluster/settings
  "persistent": {
    "xpack.monitoring.collection.interval": -1

This will stop collection of monitoring data locally, but it will allow monitoring's "cleaner service" to automatically curate the .monitoring-* indices. If you prefer to completely disable xpack.monitoring.enabled, then you will need to curate (read: delete) your old data manually.

Either way, you will then want to delete your existing monitoring indices to get the UI to start working again (you could let the old data age out, but this will work more quickly):

DELETE /.monitoring-*

Hope that helps,

I try this:
xpack.monitoring.enabled: false
and it helps

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.