Monitoring indices not created

I'm running a new prod 7.2 cluster. Want to view my ES logs in kibana as I did in dev cluster. I understand recommendation to use a seperate monitoring cluster, but for now, just want local. I set my cluster settings set dymanically to this:
{
"persistent" : {
"xpack" : {
"monitoring" : {
"elasticsearch" : {
"collection" : {
"enabled" : "true"
}
},
"collection" : {
"enabled" : "true"
}
}
}
}

but if I run GET /_cat/indices, no .monitoring* indices are created, and in kibana monitoring tab, I get no monitoring data found message.

Any suggestions?

One note, my cluster has no ingest nodes, only data, master, and coordinating. I saw in docs that for remote monitoring cluster, at least one ingest node is required, but i assumed this didn't apply for local output. Is this correct?

You do need an ingest node, even when using the local cluster for the monitoring data. You could enable ingest on the data nodes, or you could create an explicit local exporter with use_ingest set to false.

Thanks. I did just that, enabled ingest on the data nodes, and monitoring indices were created correctly.

IMO, the documentation on this point is a little ambiguous. Would help if it was clear that an ingest node is required even for local cluster monitoring.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.