Newbie question, installed everything, but getting blank page


(corpengineer) #1

Hello there:

I have current versions of Elasticsearch, Logstash, and Kibana 3 installed
on CentOS 6.5 . But when I pull up a browser, I get a black header with
text 'dashboard.current.title', and the rest of the page is blank. I also
copied the Kibana site to the plugins directory, and get the same result:

http://host.domain

and

http://host.domain:9200/_plugin/kibana3/ .

I made changes to config.js: elasticsearch: "
http://host.domain/elasticsearch" , however it is still not working. Any
suggestions re what I am missing?

Thank you for helping a Newbie.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c956c8a4-38d8-427f-ad71-05b2574f63e9%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Mark Walkom) #2

The config URL doesn't look right, it should be something like
http://elastichost.domain.com:9200/

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 18 December 2013 10:42, corpengineer@gmail.com wrote:

Hello there:

I have current versions of Elasticsearch, Logstash, and Kibana 3 installed
on CentOS 6.5 . But when I pull up a browser, I get a black header with
text 'dashboard.current.title', and the rest of the page is blank. I also
copied the Kibana site to the plugins directory, and get the same result:

http://host.domain

and

http://host.domain:9200/_plugin/kibana3/ .

I made changes to config.js: elasticsearch: "
http://host.domain/elasticsearch" , however it is still not working. Any
suggestions re what I am missing?

Thank you for helping a Newbie.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c956c8a4-38d8-427f-ad71-05b2574f63e9%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624b%2Bp11LRRQX_huhaWdBad3dGhBsJHNqdAC396WMRpCVMQ%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(corpengineer) #3

Okay I changed it to:

elasticsearch: "http://"host.domain":9200/elasticsearch/" ,

However I'm getting the same result on

http://host.domain

On Tuesday, December 17, 2013 3:45:19 PM UTC-8, Mark Walkom wrote:

The config URL doesn't look right, it should be something like
http://elastichost.domain.com:9200/

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 18 December 2013 10:42, <corpen...@gmail.com <javascript:>> wrote:

Hello there:

I have current versions of Elasticsearch, Logstash, and Kibana 3
installed on CentOS 6.5 . But when I pull up a browser, I get a black
header with text 'dashboard.current.title', and the rest of the page is
blank. I also copied the Kibana site to the plugins directory, and get the
same result:

http://host.domain

and

http://host.domain:9200/_plugin/kibana3/ .

I made changes to config.js: elasticsearch: "
http://host.domain/elasticsearch" , however it is still not working.
Any suggestions re what I am missing?

Thank you for helping a Newbie.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c956c8a4-38d8-427f-ad71-05b2574f63e9%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7c63e3bc-1701-4845-a602-82b3a328f307%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(corpengineer) #4

Also, in my reading online, I am not certain of the exact syntax. On one
site, it said something like:

elasticsearch: “http://”+window.location.hostname+”:9200″,

Should the '+' 's really be in there? I've tried with and without. I've
also made variations on where the quotes are, but it doesn't seem to change
anything (other than sometimes it comes up w/ a cryptic text page).

On Tuesday, December 17, 2013 4:04:46 PM UTC-8, corpen...@gmail.com wrote:

Okay I changed it to:

elasticsearch: "http://"host.domain":9200/elasticsearch/" ,

However I'm getting the same result on

http://host.domain

On Tuesday, December 17, 2013 3:45:19 PM UTC-8, Mark Walkom wrote:

The config URL doesn't look right, it should be something like
http://elastichost.domain.com:9200/

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 18 December 2013 10:42, corpen...@gmail.com wrote:

Hello there:

I have current versions of Elasticsearch, Logstash, and Kibana 3
installed on CentOS 6.5 . But when I pull up a browser, I get a black
header with text 'dashboard.current.title', and the rest of the page is
blank. I also copied the Kibana site to the plugins directory, and get the
same result:

http://host.domain

and

http://host.domain:9200/_plugin/kibana3/ .

I made changes to config.js: elasticsearch: "
http://host.domain/elasticsearch" , however it is still not working.
Any suggestions re what I am missing?

Thank you for helping a Newbie.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c956c8a4-38d8-427f-ad71-05b2574f63e9%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c22908b8-1e82-4fe5-ad7f-72a842c68215%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Mark Walkom) #5

You shouldn't need the /elasticsearch there.

It might be easier if you put your config(s) in a gist and then link to it,
it'll give us a better overall picture of how you have set things up.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 18 December 2013 11:08, corpengineer@gmail.com wrote:

Also, in my reading online, I am not certain of the exact syntax. On one
site, it said something like:

elasticsearch: “http://”+window.location.hostname+”:9200″,

Should the '+' 's really be in there? I've tried with and without. I've
also made variations on where the quotes are, but it doesn't seem to change
anything (other than sometimes it comes up w/ a cryptic text page).

On Tuesday, December 17, 2013 4:04:46 PM UTC-8, corpen...@gmail.com wrote:

Okay I changed it to:

elasticsearch: "http://"host.domain":9200/elasticsearch/" ,

However I'm getting the same result on

http://host.domain

On Tuesday, December 17, 2013 3:45:19 PM UTC-8, Mark Walkom wrote:

The config URL doesn't look right, it should be something like
http://elastichost.domain.com:9200/

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 18 December 2013 10:42, corpen...@gmail.com wrote:

Hello there:

I have current versions of Elasticsearch, Logstash, and Kibana 3
installed on CentOS 6.5 . But when I pull up a browser, I get a black
header with text 'dashboard.current.title', and the rest of the page is
blank. I also copied the Kibana site to the plugins directory, and get the
same result:

http://host.domain

and

http://host.domain:9200/_plugin/kibana3/ .

I made changes to config.js: elasticsearch: "http://host.domain/
elasticsearch" , however it is still not working. Any suggestions re
what I am missing?

Thank you for helping a Newbie.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/c956c8a4-38d8-427f-ad71-05b2574f63e9%
40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c22908b8-1e82-4fe5-ad7f-72a842c68215%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624ZbzHmM9EgaxAiNv5UDz5tpR8dXhyYpGwkgfEiDwN-LLw%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(corpengineer) #6

Basically, I followed this almost exactly:

http://blog.basefarm.com/blog/how-to-install-logstash-with-kibana-interface-on-rhel/

And only changed that one line in config.js.

Just removed the /elasticsearch , but same results.

Then added elasticsearch.host.domain, ditto

On Tuesday, December 17, 2013 3:42:33 PM UTC-8, corpen...@gmail.com wrote:

Hello there:

I have current versions of Elasticsearch, Logstash, and Kibana 3 installed
on CentOS 6.5 . But when I pull up a browser, I get a black header with
text 'dashboard.current.title', and the rest of the page is blank. I also
copied the Kibana site to the plugins directory, and get the same result:

http://host.domain

and

http://host.domain:9200/_plugin/kibana3/ .

I made changes to config.js: elasticsearch: "
http://host.domain/elasticsearch" , however it is still not working. Any
suggestions re what I am missing?

Thank you for helping a Newbie.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/bd72bab9-059f-45d6-82dd-f677fedc0ff3%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(corpengineer) #7

Sorry, what's a gist?

You want me to upload config.js ? Any other files?

Thank you for your help btw.

On Tuesday, December 17, 2013 4:11:14 PM UTC-8, Mark Walkom wrote:

You shouldn't need the /elasticsearch there.

It might be easier if you put your config(s) in a gist and then link to
it, it'll give us a better overall picture of how you have set things up.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 18 December 2013 11:08, <corpen...@gmail.com <javascript:>> wrote:

Also, in my reading online, I am not certain of the exact syntax. On one
site, it said something like:

elasticsearch: “http://”+window.location.hostname+”:9200″,

Should the '+' 's really be in there? I've tried with and without. I've
also made variations on where the quotes are, but it doesn't seem to change
anything (other than sometimes it comes up w/ a cryptic text page).

On Tuesday, December 17, 2013 4:04:46 PM UTC-8, corpen...@gmail.comwrote:

Okay I changed it to:

elasticsearch: "http://"host.domain":9200/elasticsearch/" ,

However I'm getting the same result on

http://host.domain

On Tuesday, December 17, 2013 3:45:19 PM UTC-8, Mark Walkom wrote:

The config URL doesn't look right, it should be something like
http://elastichost.domain.com:9200/

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 18 December 2013 10:42, corpen...@gmail.com wrote:

Hello there:

I have current versions of Elasticsearch, Logstash, and Kibana 3
installed on CentOS 6.5 . But when I pull up a browser, I get a black
header with text 'dashboard.current.title', and the rest of the page is
blank. I also copied the Kibana site to the plugins directory, and get the
same result:

http://host.domain

and

http://host.domain:9200/_plugin/kibana3/ .

I made changes to config.js: elasticsearch: "http://host.domain/
elasticsearch" , however it is still not working. Any suggestions re
what I am missing?

Thank you for helping a Newbie.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/c956c8a4-38d8-427f-ad71-05b2574f63e9%
40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c22908b8-1e82-4fe5-ad7f-72a842c68215%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9969e96d-9d88-4295-be96-259dc72f7e5c%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Mark Walkom) #8


https://gist.github.com/
Either of those.

Putting your config.js would be helpful for starters.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 19 December 2013 02:48, corpengineer@gmail.com wrote:

Sorry, what's a gist?

You want me to upload config.js ? Any other files?

Thank you for your help btw.

On Tuesday, December 17, 2013 4:11:14 PM UTC-8, Mark Walkom wrote:

You shouldn't need the /elasticsearch there.

It might be easier if you put your config(s) in a gist and then link to
it, it'll give us a better overall picture of how you have set things up.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 18 December 2013 11:08, corpen...@gmail.com wrote:

Also, in my reading online, I am not certain of the exact syntax. On
one site, it said something like:

elasticsearch: “http://”+window.location.hostname+”:9200″,

Should the '+' 's really be in there? I've tried with and without. I've
also made variations on where the quotes are, but it doesn't seem to change
anything (other than sometimes it comes up w/ a cryptic text page).

On Tuesday, December 17, 2013 4:04:46 PM UTC-8, corpen...@gmail.comwrote:

Okay I changed it to:

elasticsearch: "http://"host.domain":9200/elasticsearch/" ,

However I'm getting the same result on

http://host.domain

On Tuesday, December 17, 2013 3:45:19 PM UTC-8, Mark Walkom wrote:

The config URL doesn't look right, it should be something like
http://elastichost.domain.com:9200/

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 18 December 2013 10:42, corpen...@gmail.com wrote:

Hello there:

I have current versions of Elasticsearch, Logstash, and Kibana 3
installed on CentOS 6.5 . But when I pull up a browser, I get a black
header with text 'dashboard.current.title', and the rest of the page is
blank. I also copied the Kibana site to the plugins directory, and get the
same result:

http://host.domain

and

http://host.domain:9200/_plugin/kibana3/ .

I made changes to config.js: elasticsearch: "http://host.domain/
elasticsearch" , however it is still not working. Any suggestions
re what I am missing?

Thank you for helping a Newbie.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/c956c8a4-38d8-427f-ad71-05b2574f63e9%40goo
glegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/c22908b8-1e82-4fe5-ad7f-72a842c68215%
40googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9969e96d-9d88-4295-be96-259dc72f7e5c%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624ajOnJ6aG6Ls6g-fs9nPyL7kPx--EtoL4hXK8b2LLHGLQ%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(corpengineer) #9

Just wanted to thank you for your assistance.

I downloaded/ran Logstash v 1.3.1, and it has Kibana 3 & Elasticsearch
already embedded. Just need to write a wrapper to run as a service.
Appreciate your help.

Thank you.

On Wednesday, December 18, 2013 1:30:15 PM UTC-8, Mark Walkom wrote:

http://pastebin.com/
https://gist.github.com/
Either of those.

Putting your config.js would be helpful for starters.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 19 December 2013 02:48, <corpen...@gmail.com <javascript:>> wrote:

Sorry, what's a gist?

You want me to upload config.js ? Any other files?

Thank you for your help btw.

On Tuesday, December 17, 2013 4:11:14 PM UTC-8, Mark Walkom wrote:

You shouldn't need the /elasticsearch there.

It might be easier if you put your config(s) in a gist and then link to
it, it'll give us a better overall picture of how you have set things up.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 18 December 2013 11:08, corpen...@gmail.com wrote:

Also, in my reading online, I am not certain of the exact syntax. On
one site, it said something like:

elasticsearch: “http://”+window.location.hostname+”:9200″,

Should the '+' 's really be in there? I've tried with and without.
I've also made variations on where the quotes are, but it doesn't seem to
change anything (other than sometimes it comes up w/ a cryptic text page).

On Tuesday, December 17, 2013 4:04:46 PM UTC-8, corpen...@gmail.comwrote:

Okay I changed it to:

elasticsearch: "http://"host.domain":9200/elasticsearch/" ,

However I'm getting the same result on

http://host.domain

On Tuesday, December 17, 2013 3:45:19 PM UTC-8, Mark Walkom wrote:

The config URL doesn't look right, it should be something like
http://elastichost.domain.com:9200/

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 18 December 2013 10:42, corpen...@gmail.com wrote:

Hello there:

I have current versions of Elasticsearch, Logstash, and Kibana 3
installed on CentOS 6.5 . But when I pull up a browser, I get a black
header with text 'dashboard.current.title', and the rest of the page is
blank. I also copied the Kibana site to the plugins directory, and get the
same result:

http://host.domain

and

http://host.domain:9200/_plugin/kibana3/ .

I made changes to config.js: elasticsearch: "http://host.domain/
elasticsearch" , however it is still not working. Any suggestions
re what I am missing?

Thank you for helping a Newbie.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c956c8a4-38d
8-427f-ad71-05b2574f63e9%40googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/c22908b8-1e82-4fe5-ad7f-72a842c68215%
40googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9969e96d-9d88-4295-be96-259dc72f7e5c%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7c8f28f2-a8cc-4060-b68b-d198c1510bff%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Geovanie Marquez) #10

FYI - I solved this problem by placing the publicly visible dns in the
elasticsearch variable in the config file instead of the ip address:

from: "http://"+window.location.hostname+":9200"

WRONG:
elasticsearch: "http://IP.ADDRESS:9200"
RIGHT
elasticsearch: "http://PUBLICLY.AVAILABLE.DNS:9200",

On Thursday, December 19, 2013 3:23:26 PM UTC-5, corpen...@gmail.com wrote:

Just wanted to thank you for your assistance.

I downloaded/ran Logstash v 1.3.1, and it has Kibana 3 & Elasticsearch
already embedded. Just need to write a wrapper to run as a service.
Appreciate your help.

Thank you.

On Wednesday, December 18, 2013 1:30:15 PM UTC-8, Mark Walkom wrote:

http://pastebin.com/
https://gist.github.com/
Either of those.

Putting your config.js would be helpful for starters.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 19 December 2013 02:48, corpen...@gmail.com wrote:

Sorry, what's a gist?

You want me to upload config.js ? Any other files?

Thank you for your help btw.

On Tuesday, December 17, 2013 4:11:14 PM UTC-8, Mark Walkom wrote:

You shouldn't need the /elasticsearch there.

It might be easier if you put your config(s) in a gist and then link to
it, it'll give us a better overall picture of how you have set things up.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 18 December 2013 11:08, corpen...@gmail.com wrote:

Also, in my reading online, I am not certain of the exact syntax. On
one site, it said something like:

elasticsearch: “http://”+window.location.hostname+”:9200″,

Should the '+' 's really be in there? I've tried with and without.
I've also made variations on where the quotes are, but it doesn't seem to
change anything (other than sometimes it comes up w/ a cryptic text page).

On Tuesday, December 17, 2013 4:04:46 PM UTC-8, corpen...@gmail.comwrote:

Okay I changed it to:

elasticsearch: "http://"host.domain":9200/elasticsearch/" ,

However I'm getting the same result on

http://host.domain

On Tuesday, December 17, 2013 3:45:19 PM UTC-8, Mark Walkom wrote:

The config URL doesn't look right, it should be something like
http://elastichost.domain.com:9200/

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 18 December 2013 10:42, corpen...@gmail.com wrote:

Hello there:

I have current versions of Elasticsearch, Logstash, and Kibana 3
installed on CentOS 6.5 . But when I pull up a browser, I get a black
header with text 'dashboard.current.title', and the rest of the page is
blank. I also copied the Kibana site to the plugins directory, and get the
same result:

http://host.domain

and

http://host.domain:9200/_plugin/kibana3/ .

I made changes to config.js: elasticsearch: "http://host.domain/
elasticsearch" , however it is still not working. Any suggestions
re what I am missing?

Thank you for helping a Newbie.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c956c8a4-38d
8-427f-ad71-05b2574f63e9%40googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/c22908b8-1e82-4fe5-ad7f-72a842c68215%
40googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9969e96d-9d88-4295-be96-259dc72f7e5c%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
This email, including any attachments, contains information that is
privileged, confidential, and/or otherwise exempt from disclosure under
applicable law. If you are not the intended recipient, then any disclosure,
dissemination, distribution, copying, or any other use of this
communication or its contents is prohibited. If you have received this
email in error, please notify the sender immediately and destroy all
electronic and hard copies of this email and its attachments.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b15f2c3f-fb30-4566-a080-616a778d6811%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jilles van Gurp) #11

The default should be fine if you have port 9200 open. I've been messing
around with kibana as well and it isn't the most friendly to setup. I'd
prefer the way e.g. elasticsearch-head works, which simply allows you to
paste a url in the UI. I can run elasticsearch-head straight from the git
directory by opening index.html from the filesystem and then pasting the
right url. No need to mess around with es plugins. This doesn't work for
kibana unfortunately.

A simple way to get started is using ssh tunnels. Simply put kibana on any
web server that can serve static content, and point config.js at
http://localhost:9200. Then simply create an ssh tunnel: ssh -L
9200:localhost:9200 user@elasticsearchboxip to tunnel the elasticsearch
traffic to localhost and point your browser at kibana. This is probably the
easiest to setup and get working (short of running everything on localhost).

This bypasses the need to set up elaborate security. This is more secure as
well since it doesn't require you to lock down nginx enough so that an
enterprising hacker doesn't get full access to all your data in
elasticsearch.

In our current setup, I have a nginx hosting kibana and proxying
elasticsearch over https with basic authentication. I've tuned it such that
you only have read only access to elastic search (except for the index that
kibana uses to store its settings).

Jilles

On Wednesday, December 18, 2013 1:08:42 AM UTC+1, corpen...@gmail.com wrote:

Also, in my reading online, I am not certain of the exact syntax. On one
site, it said something like:

elasticsearch: “http://”+window.location.hostname+”:9200″,

Should the '+' 's really be in there? I've tried with and without. I've
also made variations on where the quotes are, but it doesn't seem to change
anything (other than sometimes it comes up w/ a cryptic text page).

On Tuesday, December 17, 2013 4:04:46 PM UTC-8, corpen...@gmail.com wrote:

Okay I changed it to:

elasticsearch: "http://"host.domain":9200/elasticsearch/" ,

However I'm getting the same result on

http://host.domain

On Tuesday, December 17, 2013 3:45:19 PM UTC-8, Mark Walkom wrote:

The config URL doesn't look right, it should be something like
http://elastichost.domain.com:9200/

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 18 December 2013 10:42, corpen...@gmail.com wrote:

Hello there:

I have current versions of Elasticsearch, Logstash, and Kibana 3
installed on CentOS 6.5 . But when I pull up a browser, I get a black
header with text 'dashboard.current.title', and the rest of the page is
blank. I also copied the Kibana site to the plugins directory, and get the
same result:

http://host.domain

and

http://host.domain:9200/_plugin/kibana3/ .

I made changes to config.js: elasticsearch: "
http://host.domain/elasticsearch" , however it is still not working.
Any suggestions re what I am missing?

Thank you for helping a Newbie.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c956c8a4-38d8-427f-ad71-05b2574f63e9%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0af8a7c8-9a1a-4157-9623-9a74f00e88cc%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Fernando Emwferm) #12

Hej:

I was also testing this and had some issue. When running the embedded
logstash(1.3.3)-elasticsearch-kibana was working perfect but as separate
components I was having issues. When it comes to Kibana I downloaded Kibana
3 Milestone 4 and after reading a lot I realized that Kibana needs to be
installed together with a Web server (this is how newbie I am). Now for the
config.js the value that I am using is:

elasticsearch: "http://localhost:9200",

And then I have elasticsearch 0.90.9 which is started also in the 9200 port
by making sure that the config/elasticsearch.yml configuration file
contains the following line:

http.port: 9200
Then in my case before installing any web server I found you can run a
small Simple Web Server using python with the following instruction:

python -m SimpleHTTPServer 8080

You have to run this command from the main Kibana directory (where the
config.js and index.html files are). I am using SSH Tunneling so I open
ports 9200 and 8080 for localhost. Then I point my web browser to

http://localhost:8080/index.html

And I could see Kibana dashboard but if there is no indexed information in
the elasticsearch data directory it reports and Error:

Error No index found at http://localhost:9200/_all/_mapping. Please
create at least one index.If you're using a proxy ensure it is configured
correctly.

The error clears when you have inserted data via logstash.

Hope this helps,
s.r./F

On Wednesday, December 18, 2013 12:42:33 AM UTC+1, corpen...@gmail.com
wrote:

Hello there:

I have current versions of Elasticsearch, Logstash, and Kibana 3 installed
on CentOS 6.5 . But when I pull up a browser, I get a black header with
text 'dashboard.current.title', and the rest of the page is blank. I also
copied the Kibana site to the plugins directory, and get the same result:

http://host.domain

and

http://host.domain:9200/_plugin/kibana3/ .

I made changes to config.js: elasticsearch: "
http://host.domain/elasticsearch" , however it is still not working. Any
suggestions re what I am missing?

Thank you for helping a Newbie.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/08b63e79-7ad6-42c9-9642-f7fe1e807bf0%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Geovanie Marquez) #13

This allowed me to get ES working without logstash: (standalone)

sudo bin/elasticsearch

I placed some data into the ES index there are plenty of examples of
placing dummy data in.

Now to get Kibana to show up:
I set this up on a server in the cloud and accessed it from my localhost.
cd /opt
sudo wget
https://download.elasticsearch.org/kibana/kibana/kibana-3.0.0milestone5.zip
mkdir -p /opt/elasticsearch-1.0.0/plugins/kibana/_site
sudo cp -r kibana-3.0.0milestone5/*
elasticsearch-1.0.0/plugins/kibana/_site/
sudo /opt/elasticsearch-1.0.0/plugins/kibana/_site/config.js
change the following parameter to the publicly facing dns:
from: "http://"+window.location.hostname+":9200"
to: elasticsearch: "http://FULL_PUBLIC_DOMAIN_OF_HOST:9200",

Then I use Google Chrome Plugin Sense to take a look at my index data using
the public domain

[image: Inline image 1] Geovanie Marquez
Scalability Engineer
Wellcentive, Inc.
100 Mansell Court East, Suite 625
Roswell, GA 30076


910.376.4893 Mobile
678.710.2005 Fax

[image: Inline image 2] http://www.facebook.com/Wellcentive [image:
Inline image 3] http://twitter.com/Wellcentive [image: Inline image
4]http://www.linkedin.com/company/wellcentive

On Tue, Feb 18, 2014 at 5:31 AM, Fernando Emwferm emwferm@gmail.com wrote:

Hej:

I was also testing this and had some issue. When running the embedded
logstash(1.3.3)-elasticsearch-kibana was working perfect but as separate
components I was having issues. When it comes to Kibana I downloaded Kibana
3 Milestone 4 and after reading a lot I realized that Kibana needs to be
installed together with a Web server (this is how newbie I am). Now for the
config.js the value that I am using is:

elasticsearch: "http://localhost:9200",

And then I have elasticsearch 0.90.9 which is started also in the 9200
port by making sure that the config/elasticsearch.yml configuration file
contains the following line:

http.port: 9200
Then in my case before installing any web server I found you can run a
small Simple Web Server using python with the following instruction:

python -m SimpleHTTPServer 8080

You have to run this command from the main Kibana directory (where the
config.js and index.html files are). I am using SSH Tunneling so I open
ports 9200 and 8080 for localhost. Then I point my web browser to

http://localhost:8080/index.html

And I could see Kibana dashboard but if there is no indexed information in
the elasticsearch data directory it reports and Error:

Error No index found at http://localhost:9200/_all/_mapping. Please
create at least one index.If you're using a proxy ensure it is configured
correctly.

The error clears when you have inserted data via logstash.

Hope this helps,
s.r./F

On Wednesday, December 18, 2013 12:42:33 AM UTC+1, corpen...@gmail.comwrote:

Hello there:

I have current versions of Elasticsearch, Logstash, and Kibana 3
installed on CentOS 6.5 . But when I pull up a browser, I get a black
header with text 'dashboard.current.title', and the rest of the page is
blank. I also copied the Kibana site to the plugins directory, and get the
same result:

http://host.domain

and

http://host.domain:9200/_plugin/kibana3/ .

I made changes to config.js: elasticsearch: "http://host.domain/
elasticsearch" , however it is still not working. Any suggestions re
what I am missing?

Thank you for helping a Newbie.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/nN79-lWeZ9Y/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/08b63e79-7ad6-42c9-9642-f7fe1e807bf0%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
This email, including any attachments, contains information that is
privileged, confidential, and/or otherwise exempt from disclosure under
applicable law. If you are not the intended recipient, then any disclosure,
dissemination, distribution, copying, or any other use of this
communication or its contents is prohibited. If you have received this
email in error, please notify the sender immediately and destroy all
electronic and hard copies of this email and its attachments.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAF5idwtv2L1NOzYHhjNFqi_ALtbp65DRfMfMdMLkxgVoyJHg7g%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Tony Su) #14

IMO based on what I've done and observed:

  • Should not matter whether you use the IP address or FQDN in a URL as long
    as the FQDN maps to the same IP address. So, Geovanie's problem with this
    is likely a HOSTNAME mapping problem where the HOSTNAME is correct.

  • I don't know that the SSH tunnel described by Jilles is effective at all.
    AFAIK as long as "localhost" is mapped to lo and not a real network
    interface which communicates with other nodes, I find it hard to conceive
    how there is a security issue (maybe someone will point out something I'm
    missing?). Additionally, if you're trying to secure access to cluster
    information, this won't do it. AFAIK securing a connection to any one Host
    (eg localhost even if it was done) won't prevent someone from querying any
    other node in the Cluster which would then happily respond because ES today
    does not integrate with any kind of security (If someone is looking into
    this, I'd suggest PAM support which would theoretically enable practically
    any kind of network security authentication). And, remember that a browser
    or webserver is not a requirement for querying for cluster data, ES
    supports curl using the exact same statements.

IMO and AFAIK,
Tony

On Tuesday, February 18, 2014 12:15:00 AM UTC-8, Jilles van Gurp wrote:

The default should be fine if you have port 9200 open. I've been messing
around with kibana as well and it isn't the most friendly to setup. I'd
prefer the way e.g. elasticsearch-head works, which simply allows you to
paste a url in the UI. I can run elasticsearch-head straight from the git
directory by opening index.html from the filesystem and then pasting the
right url. No need to mess around with es plugins. This doesn't work for
kibana unfortunately.

A simple way to get started is using ssh tunnels. Simply put kibana on any
web server that can serve static content, and point config.js at
http://localhost:9200. Then simply create an ssh tunnel: ssh -L
9200:localhost:9200 user@elasticsearchboxip to tunnel the elasticsearch
traffic to localhost and point your browser at kibana. This is probably the
easiest to setup and get working (short of running everything on localhost).

This bypasses the need to set up elaborate security. This is more secure
as well since it doesn't require you to lock down nginx enough so that an
enterprising hacker doesn't get full access to all your data in
elasticsearch.

In our current setup, I have a nginx hosting kibana and proxying
elasticsearch over https with basic authentication. I've tuned it such that
you only have read only access to elastic search (except for the index that
kibana uses to store its settings).

Jilles

On Wednesday, December 18, 2013 1:08:42 AM UTC+1, corpen...@gmail.comwrote:

Also, in my reading online, I am not certain of the exact syntax. On one
site, it said something like:

elasticsearch: “http://”+window.location.hostname+”:9200″,

Should the '+' 's really be in there? I've tried with and without. I've
also made variations on where the quotes are, but it doesn't seem to change
anything (other than sometimes it comes up w/ a cryptic text page).

On Tuesday, December 17, 2013 4:04:46 PM UTC-8, corpen...@gmail.comwrote:

Okay I changed it to:

elasticsearch: "http://"host.domain":9200/elasticsearch/" ,

However I'm getting the same result on

http://host.domain

On Tuesday, December 17, 2013 3:45:19 PM UTC-8, Mark Walkom wrote:

The config URL doesn't look right, it should be something like
http://elastichost.domain.com:9200/

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 18 December 2013 10:42, corpen...@gmail.com wrote:

Hello there:

I have current versions of Elasticsearch, Logstash, and Kibana 3
installed on CentOS 6.5 . But when I pull up a browser, I get a black
header with text 'dashboard.current.title', and the rest of the page is
blank. I also copied the Kibana site to the plugins directory, and get the
same result:

http://host.domain

and

http://host.domain:9200/_plugin/kibana3/ .

I made changes to config.js: elasticsearch: "
http://host.domain/elasticsearch" , however it is still not working.
Any suggestions re what I am missing?

Thank you for helping a Newbie.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c956c8a4-38d8-427f-ad71-05b2574f63e9%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/bad357a4-d1b2-4cb7-88cf-48096d5ad644%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Tony Su) #15

I have found 3 ways of launching Kibana 3

  1. If you're just setting up a Demo, you can launch an embedded version
    without d/l and installing any files if you're using Logstash, just append
    "-- web" to the end of the Logstash statement,
    eg java -jar logstash -f configfile -- web

Then, just open a web browser to localhost:9292

  1. Install as a plugin. If you do this, then you do need to use the url
    with that includes "_plugin" eg
    http://localhost:9200/_plugin/...

  2. Personally, I prefer to just run in a webserver, for this I just d/l the
    TAR file, extract and copy or move the file to the webserver root. Then,
    you can open a browser to
    http://localhost
    Note that part of why I prefer this last method is that I can also deploy
    other web tools like es-head and es-hq to the same website, if I extract
    the TAR files (or simply git clone them) and copy to the
    webserver's root (including the parent directory of the new additions) then
    those can also be accessed as subdirectories, eg
    http://localhost/elasticsearch-head/
    http://localhost/elasticsearch-hq/

HTH,
Tony

On Tuesday, December 17, 2013 3:42:33 PM UTC-8, corpen...@gmail.com wrote:

Hello there:

I have current versions of Elasticsearch, Logstash, and Kibana 3 installed
on CentOS 6.5 . But when I pull up a browser, I get a black header with
text 'dashboard.current.title', and the rest of the page is blank. I also
copied the Kibana site to the plugins directory, and get the same result:

http://host.domain

and

http://host.domain:9200/_plugin/kibana3/ .

I made changes to config.js: elasticsearch: "
http://host.domain/elasticsearch" , however it is still not working. Any
suggestions re what I am missing?

Thank you for helping a Newbie.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e69de89c-351b-4cf9-b257-8b40bcbe76b8%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #16