Not able to create index pattern in kibana 6.8.1

HI,

i have installed ELK STACK and i am trying to create an index pattern in kibana but its not creating ?

can someone one please tell me what wrong i have done ? and help me solve it .

that loading is running for hours but its not creating any index .

Hi

What are the errors in the Kibana and ES logs ? Can you elaborate more further ?

Thanks
Rashmi

Hi @rashmi thanks for the reply.
I'm sorry i cant able to find my kibana logs.

Have a look at my elasticsearch logs:

[2019-06-28T21:39:29,154][INFO ][o.e.c.m.MetaDataIndexTemplateService] [YWG9VCA] adding template [.management-beats] for index patterns [.mangement-beats]

[2019-06-28T21:39:50,002][WARN ][o.e.c.r.a.DiskThresholdMonitor] [YWG9VCA] flood stage disk watermark [95%] exceeded on [YWG9VCAsQwm7rYvNT57S8A][YWG9VCA][/var/lib/elasticsearch/nodes/0] free: 28gb[3.1%] , all indices on this node will be marked read-only
[2019-06-28T21:40:20,005][WARN ][o.e.c.r.a.DiskThresholdMonitor] [YWG9VCA] flood stage disk watermark [95%] exceeded on [YWG9VCAsQwm7rYvNT57S8A][YWG9VCA][/var/lib/elasticsearch/nodes/0] free: 28gb[3.1%] , all indices on this node will be marked read-only
[2019-06-28T21:40:50,006][WARN ][o.e.c.r.a.DiskThresholdMonitor] [YWG9VCA] flood stage disk watermark [95%] exceeded on [YWG9VCAsQwm7rYvNT57S8A][YWG9VCA][/var/lib/elasticsearch/nodes/0] free: 28gb[3.1%] , all indices on this node will be marked read-only
[2019-06-28T21:41:20,011][WARN ][o.e.c.r.a.DiskThresholdMonitor] [YWG9VCA] flood stage disk watermark [95%] exceeded on [YWG9VCAsQwm7rYvNT57S8A][YWG9VCA][/var/lib/elasticsearch/nodes/0] free: 28gb[3.1%] , all indices on this node will be marked read-only
[2019-06-28T21:41:50,016][WARN ][o.e.c.r.a.DiskThresholdMonitor] [YWG9VCA] flood stage disk watermark [95%] exceeded on [YWG9VCAsQwm7rYvNT57S8A][YWG9VCA][/var/lib/elasticsearch/nodes/0] free: 28gb[3.1%] , all indices on this node will be marked read-only

oh as the stack trace indicates , you have reached high watermark. cluster.routing.allocation.disk.watermark.flood_stage this setting defaults to 95%, meaning that Elasticsearch enforces a read-only index block ( index.blocks.read_only_allow_delete ) on every index that has one or more shards allocated on the node that has at least one disk exceeding the flood stage. This is a last resort to prevent nodes from running out of disk space. The index block must be released manually once there is enough disk space available to allow indexing operations to continue. https://www.elastic.co/guide/en/elasticsearch/reference/current/disk-allocator.html

May be delete the .kibana index and restart ? There may be other things which might be hogging your network as well.

HI @rashmi .

i have deleted the kibana index and restarted the kibana still im not able to create an index pattern.

Can you also delete the data directory and restart Kibana again. Looks like somethings corrupt. It works perfectly fine for me on 6.8.1

Thanks
Rashmi

Thanks @rashmi ,
i just reinstalled it, it's working now.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.