Not show X Axis value in graphs


#1

Hi,

Ive created a graph which displays some nontime series data. There are about 1000+ rows (values) in the X-Axis due to which the values are displayed as gibberish. How can I configure the graph to not show the X-Axis values?

--Syd


(Tyler Smalley) #2

When you setup the index pattern, did you uncheck "Index contains time-based events "


#3

Yes unchecked the option Index contains time-based events


(Tyler Smalley) #4

What does your data look like and how do you have your visualization configured to produce 1000 values on the x-axis? Term with size 1000?


#5

For this use case, I have data in sqlite that Im sending to Elasticsearch through a python script. Data contains various fields or columns which have a common factor the row id. So about a 1000 rows which I then try to graph in Kibana using the max value of one of the column in Y axis and the row id on X axis. Term size is set to 1000 for Xaxis hence all the X axis values are listed and sort of overlap resulting in gibberish text. Im able to get the corresponding graph value of by enabling tooltip hence want to disable values for Xaxis
Disabling value of X axis is available in Grafana I believe and I wanted to replicate the same behaviour in Kibana.

Screenshot of the graph attached


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.