NSSM, Connect ECONNREFUSED, Unable to revive connection, No living connections


(Kelsey Forsythe) #1

I'm on a Windows 2016 Server Virtual Machine. The Windows Firewall is turned off on this machine as is HIPS. We are using Internet Explorer browser. Both Elasticsearch and Kibana are installed on this VM.
I've installed Elasticsearch 6.6.1 and have a trial Xpack license.
I've verified that Elasticsearch is running by navigating to http:[VM's fully qualified domain name]:9200, entering the elastic credentials when prompted and it returns a .json file (actually prompts me to open or save) with info about the Elasticsearch software.
I installed Kibana 6.6.2 (unzipped) and ran setup_kibana which returned 'Service "Elasticsearch Kibana 6.6.2" installed successfully! BUT it also returned "Unexpected status SERVICE_PAUSED in response to START control". When I tried to navigate to http://[VM's fully qualified domain name]:5601 it returns "This page can't be displayed" error. When I tried to start the Service in the Services console I receive:
'Windows could not start the Elasticsearch Kibana 6.6.2...The service did not return an error'
I explored the Event logs and found reference to NSSM(The non-sucking service manager) which I understand is a wrapper service manager for the associated kibana.bat file. It states:
'Service Elasticsearch Kibana 6.6.2 ran for less than 1500 milliseconds. Restart will be delayed by 32000 milliseconds'. Should I run nssm edit [Kibana service name] and adjust some of those parameters? Is NSSM necessary considering we already have the Services console? If so, can I disable it?
I also tried to run the kibana.bat file manually from Powershell as administrator and receive multiple errors retrying GET http://[elasticsearch VM host name]:9200/_xpack=> connect ECONNREFUSED [IP address of Elasticsearch VM host]:9200...Unable to revive connection....No living connections. The Windows Firewall is turned off on this machine as is HIPS so I don't understand why the connection to that port would be refused. Any suggestions or ideas are welcome.

Thank you,

v/r
Kelsey


(Tiago Costa) #2

@namnyefr from the provided info you are running elasticsearch@6.6.1 and kibana@6.6.2. Please run both services under version 6.6.2 and let me know if it worked then :slight_smile:

Otherwise, could you provide more info as the entire logs both for kibana, elasticsearch and also the curl result for each services urls?


(system) closed #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.