Phantom immediately exited with: 127

reporting

#1

I've just finished installing Reporting and have tried several times to generate a report, however every time i try I receive the following text "Phantom immediately exited with: 127" and the report fails.

Any advice gratefully received.

Thanks in advance.


(Mark Walkom) #2

What version of things are you on?


#3

I just upgraded everything today in order to try reporting.

I am using the following:

Reporting - 2.4
Elasticsearch - 2.4
Logstash - 2.4
Kibana - 4.6

Thanks


(Antonio Bonuccelli) #4

see here https://www.elastic.co/guide/en/reporting/current/getting-started.html

Ubuntu users may need to install some additional dependencies. If report generation fails with the error "Phantom immediately exited with: 127" you’ll need to install libfontconfig and libfreetype6 via apt.


#5

I'm running on Redhat 7.2 but i will take look at the dependencies you mentioned.


#6

As nellicus commented - I have installed fontconfig on the redhat 7.2 server and everything is now working fine.

Thank you all for your assistance.


(Mark Walkom) #7

Great!
We'll get the docs updated as well :slight_smile:


(gearoid) #8

100% spot on, just ran the following:
sudo apt install -y libfontconfig
sudo apt install -y libfreetype6
and reporting worked.
Thanks


(system) #9