Problem Plotting Zero values with Kibana


(shriyansh jain) #1

Hi,

I am using a ELK stack for log processing. One of the problem I am facing
with kibana is that, I have some fields in my log whose values is zero, and
zero is considered as legitimate value in my case. But when I plot those
fields in kibana, if zero field is enabled it plots zero in the graph
including the gaps. But I dont want to plot the zero values in the gaps, I
just want to plot my actual log values in the graph, but kibana doent seem
to be able to do that. Am I going anywhere wrong or is kibana really not
able to visualize that.?

Thank you,
Shriyansh

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/cd54f92f-737a-4af1-b6cb-5b2f00a75fc2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

This was just answered on your post to the LS list, but you can set zero
fill under panel settings.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 12 August 2014 09:50, shriyansh jain shriyanshajain@gmail.com wrote:

Hi,

I am using a ELK stack for log processing. One of the problem I am facing
with kibana is that, I have some fields in my log whose values is zero, and
zero is considered as legitimate value in my case. But when I plot those
fields in kibana, if zero field is enabled it plots zero in the graph
including the gaps. But I dont want to plot the zero values in the gaps, I
just want to plot my actual log values in the graph, but kibana doent seem
to be able to do that. Am I going anywhere wrong or is kibana really not
able to visualize that.?

Thank you,
Shriyansh

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/cd54f92f-737a-4af1-b6cb-5b2f00a75fc2%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/cd54f92f-737a-4af1-b6cb-5b2f00a75fc2%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624b0M%3D59UauSebQ3%3D7pSG3pOyBiiX-J5oTaMAorYQK0NZQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(shriyansh jain) #3

Hi,
Thank you for your reply back. I am aware of the zero fill settings in
kibana.
But my problem is I have some log values which are zero at particular
timestamp and don't have any values at some timestamp. So if I select zero
fill it plots zero for both the actual zero values and the values where
there are gaps.
I want to plot the values where I am actually getting zero and plot nothing
where I have gaps. Is that possible .?

Thank you,
Shriyansh

On Monday, August 11, 2014 4:54:17 PM UTC-7, Mark Walkom wrote:

This was just answered on your post to the LS list, but you can set zero
fill under panel settings.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 12 August 2014 09:50, shriyansh jain <shriyan...@gmail.com
<javascript:>> wrote:

Hi,

I am using a ELK stack for log processing. One of the problem I am facing
with kibana is that, I have some fields in my log whose values is zero, and
zero is considered as legitimate value in my case. But when I plot those
fields in kibana, if zero field is enabled it plots zero in the graph
including the gaps. But I dont want to plot the zero values in the gaps, I
just want to plot my actual log values in the graph, but kibana doent seem
to be able to do that. Am I going anywhere wrong or is kibana really not
able to visualize that.?

Thank you,
Shriyansh

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/cd54f92f-737a-4af1-b6cb-5b2f00a75fc2%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/cd54f92f-737a-4af1-b6cb-5b2f00a75fc2%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c654db5f-10f5-4c8c-9389-8ff847cf8914%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4