Production cluster doesn't show up in Kibana on monitoring cluster

monitoring

(Jérémy Lecour) #1

Hi

I have a production cluster called "elastic1" with 4 nodes (version 6.3.1). It's been running for a few months.
I also have built a cluster called "elastic2" (1 node only, version 6.4.2) to collect monitoring data.

I have configured my production cluster to export the monitoring data to the monitoring cluster. It seems to work since I don't have any local monitoring data on the production cluster anymore.
But in Kibana on the monitoring cluster data I can only see the local data (for the monitoring cluster itself).

In the "Monitoring" section of Kibana i see only 1 cluster (the local one) and even if I change the URL to use the production cluster UUDI it goes back to the other one.

I've tried to restart Elasticsearch and Kibana on the monitoring cluster.
I've verified that data from the production cluster arrives in the ".monitoring-es6-YYYY-mm-dd" indices.

Is there something else to enable in order to view monitoring data for remote clusters?


(Shaunak Kashyap) #2

Hi, could you share your kibana.yml and elasticsearch.yml files, please, with any sensitive information masked?


(Jérémy Lecour) #3

Hi, the mysterious issue is solved!

When I've upgraded the production cluster I suddenly had a message in the monitoring section telling me that with a "basic" license we can't monitor multiple clusters on a single one.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.