Rebind Kibana to localhost only

I've been asked to rebind Kibana to "localhost only." Does this imply I shouldn't be using port 5601?

What exactly does this mean, and how can I check that I've successfully rebound Kibana to localhost only? (Ubuntu 16)

BTW, I'm using Nginx to access the Kibana dashboard. In my Nginx config file, I have the line

proxy_pass http://localhost:5601;

So does that mean Kibana is not bound to localhost only because it still uses port 5601?


  server {
      listen 80 default_server;
      server_name _;
      return 301 https://$host$request_uri;
  server {
      listen 443 ssl;
      include snippets/signed.conf;
      include snippets/ssl-params.conf;
      server_name x.x.x.x;
      auth_basic "Restricted Access";
      auth_basic_user_file /etc/nginx/htpasswd.users;
      location / {
          proxy_pass http://localhost:5601;
          proxy_http_version 1.1;
          proxy_set_header Upgrade $http_upgrade;
          proxy_set_header Connection 'upgrade';
          proxy_set_header Host $host;
          proxy_cache_bypass $http_upgrade;

(My entire /etc/kibana/kibana.yml is commented out)

You can control what address Kibana binds to by configuring the option in kibana.yml. We only bind to localhost by default.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.