Remote monitoring cluster, no ES data


(Pjanzen) #1

Hi All,

I have followed this guide: monitoring-production to setup my elasticsearch / logstash / kibana monitoring and when I look on my monitor cluster trough kibana -> monitoring I have an overview of elasticsearch, kibana and logstash. For logstash and kibana I see my remote nodes but for elasticsearch I don't see them.

I am using version 6.2.4 for all components.

The monitoring elasticsearch config looks like this.

cluster.name: clog-monitoring
node.name: tb-clog-emon1.xxx.local
path.data: /opt/elasticdb/data
path.logs: /var/log/elasticsearch
bootstrap.memory_lock: true
network.host: ['10.80.3.80', '127.0.0.1']
discovery.zen.master_election.ignore_non_master_pings: true
discovery.zen.ping.unicast.hosts: ["10.80.3.80","10.80.3.81","10.80.3.82","10.80.3.83","10.80.3.84"]
xpack.monitoring.enabled: true
xpack.security.enabled: false
xpack.monitoring.collection.indices: ''
http.cors.enabled: true
http.cors.allow-origin: "/.
/"
transport.tcp.compress: true
node.attr.box_type: no_data

My elasticsearch data nodes looks like this.

cluster.name: clog
node.name: tb-clog-esd1.tb.iss.local
path.data: /opt/elasticdb/data
path.logs: /var/log/elasticsearch
bootstrap.memory_lock: true
network.host: ['10.80.3.11', '127.0.0.1']
discovery.zen.master_election.ignore_non_master_pings: true
discovery.zen.ping.unicast.hosts: ["10.80.3.10","10.80.3.11","10.80.3.12","10.80.3.13","10.80.3.14","10.80.3.15","10.80.3.16","10.80.3.17","10.80.3.18","10.80.3.19","10.80.3.20","10.80.3.2
1","10.80.3.22","10.80.3.23","10.80.3.24","10.80.3.25","10.80.3.26","10.80.3.27","10.80.3.28","10.80.3.29","10.80.3.30","10.80.3.4","10.80.3.5","10.80.3.6","10.80.3.7","10.80.3.8","10.80.3
.9"]
xpack.security.enabled: false
node.master: false
node.data: true
node.ingest: true
xpack.monitoring.collection.indices: clog-*
xpack.monitoring.exporters:
  id1:
    type: http
    host: ['10.80.3.80','10.80.3.81','10.80.3.82','10.80.3.83','10.80.3.84']
gateway.recover_after_time: 2m
discovery.zen.minimum_master_nodes: 2
gateway.recover_after_nodes: 12
gateway.expected_data_nodes: 20
http.cors.enabled: true
http.cors.allow-origin: "/.*/"
transport.tcp.compress: true
node.attr.box_type: ssd

For completeness, this is how my logstash.yml is looking.

node.name: tb-clog-ls1
path.config: /etc/logstash/conf.d
path.data: /var/lib/logstash
path.logs: /opt/logstash/logs
#pipeline.workers: 20
#pipeline.output.workers: 20
http.host: 0.0.0.0
http.port: 9600-9700
xpack.monitoring.enabled: true
xpack.monitoring.elasticsearch.url: ["http://10.80.3.80:9200", "http://10.80.3.81:9200", "http://10.80.3.82:9200", "http://10.80.3.83:9200", "http://10.80.3.84:9200"]
xpack.monitoring.elasticsearch.username: "elastic"
xpack.monitoring.elasticsearch.password: "changeme"

(Pjanzen) #2

Ok, the config needs to be on all the nodes in your cluster, not just your data nodes.

Pushed config to all ES nodes and problem is solved.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.