Set kibana.autocompleteTerminateAfter via DevTools


Is there a way to set kibana.autocompleteTerminateAfter via DevTools or via curl command?
Thank you in advance!


No, this setting is only configurable via kibana.yml file or environment variable of the Kibana server process.

I have a belk deployment, so in which pod should I make this change?
elasticsearch-master, elasticsearch-client, elasticsearch-data or kibana pod?
Can this change made "on the fly"?

It has to be made in the kibana pod as this is a kibana-specific setting. I think you have to restart the Kibana process for this setting to take effect.

This parameter it is missing from kibana.yaml. What is the default value for that?

All common config keys are documented here:

I have seen this, thank you. But in case is missing is there any default value?
Thanks again.

We might be looking at two different things here - this is the section about kibana.autocompleteTerminateAfter:

Probably :slight_smile:
Thank you a lot !

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.