Snapshot Kibana 6.8 under Windows


I am trying to setup Kibana to create a snapshot but I am missing the setting - Register a repository - in Kibana 6.8
I add already in the elasticsearch.yml - path.repo: E:\Program Files\Elastic\\Elasticsearch

Than I need to restore it in Kibana 7.10

I didn't find this problem in the Forum.

Thank you a lot

I manage to create the Repository but I can't create the Backup

Thank you

What's the name of the repository? If it's my_fs_backup, use that name instead.

Please don't post images of text as they are hard to read, may not display correctly for everyone, and are not searchable.

Instead, paste the text and format it with </> icon or pairs of triple backticks (```), and check the preview window to make sure it's properly formatted before posting it. This makes it more likely that your question will receive a useful answer.

This is how I created it

PUT /_snapshot/Backup
     "type": "fs",
      "settings": {
        "compress" : true,
        "location": "my_backup_location"

It created the Folder ''my_backup_location''
Isn't it the name Backup in this case ?

Yes. But Backup is not backup I guess :wink:

I am step closer :slight_smile: I could also create the Backup with this cmd
PUT /_snapshot/Backup/my_snapshot
Now how do I restore the Backup from version 6.8 to 7.10.1
Do I just copy the files from the 6.8 Server to the 7.10.1 Server ?
Thank you

Do the same thing you did but in the new cluster.
If possible just mount the shared fs in the new cluster as well. I'd probably mount it as read only probably.

so basicaly you mean

  • I create the Repo
  • copy the files from the old location to the new location
  • I need to create a backup otherwise there is no option to restore it directly

There is just one server so there is no cluster.

i am a step closer, I could import the Backup but I cannot restore it.
I got this Error

[invalid_index_name_exception] Invalid index name [.kibana_task_manager], already exists as alias, with { index_uuid="_na_" & index=".kibana_task_manager" }

Do not import the .kibana_task_manager index.

You should actually restore only the indices which contains the real data.

Or you will most likely have to close the indices first then restore I guess.

Doc says:

However, an existing index can be only restored if it’s closed and has the same number of shards as the index in the snapshot. The restore operation automatically opens restored indices if they were closed and creates new indices if they didn’t exist in the cluster.

I could restore the Indices from last year but there is one from this year where i got this message

[snapshot_restore_exception] [my_backup_location:my_snapshot/HX1xrkZ2SZWIZ3q0o82DdQ] cannot restore index [logflow-2021.01] with [1] shards from a snapshot of index [logflow-2021.01] with [5] shards

The index already exists with a different number of shards. It can be restored.

If you don't have existing data in it, run:

DELETE logflow-2021.01

Otherwise, you can may be do a reindex from remote to reindex only the recent data
for January from the old cluster to the new one.

Thank you, now it worked. Yes I delete the Index and than restored. It was the easyear way.
For now the Restore from backup Problem is solved.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.