Tableau Connector with TLS on HTTP layer

How do I configure the tableau connector Elasticsearch by Elastic to include the certificate for my production cluster?

I have followed the instructions to Set up basic security for the Elastic Stack plus secured HTTPS traffic for my production cluster. I am now trying to connect to my prod cluster with Tableau Desktop. I have followed the instructions to Download Tableau Connector for Elasticsearch.

In the tableau connection dialog box I have specified the server name for one of my nodes, port 9200, the username/password for a read-only user I created specifically for this connection, and selected the "Require SSL" checkbox.

When I select Sign In I get this error: Cannot POST address (PKIX path building failed: unable to find valid certification path to requested target) Unable to connect to the Elasticsearch by Elastic server "". Check that the server is running and that you have access privileges to the requested database. Connector Class: elasticsearch-jdbc, Version: 1.0.0

On the node I am trying to connect to I see this error being logged: http client did not trust this server's certificate, closing connection Netty4HttpChannel{localAddress=/, remoteAddress=/}

I think the issue is that I am not specifying the certificate anywhere in my tableau connection dialogue box. How do I specify it, in the Additional settings box? And what certificate should I use, the same one my Kibana is using?

In case anyone else has the same problem...

I resolved this issue by installing on my workstation the same certificate that I am using to connect kibana to tableau. I googled to find instructions on installing a certificate on my machine.

Then I was able to connect in tableau but no database or tables were showing. I discovered the problem there was that the jdbc driver version I had downloaded (7.15.2) was incompatible with the version of Elasticsearch I had running (7.15.1). I downloaded the older version of the jdbc driver and was able to access the data in my cluster.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.