TSVB Start of day showing 6:00 pm when using Interval 1d


(Dallas Toth) #1

In this video you can see that in Discovery there are 19 count for the 24th 1 of those items at 6:05 pm (18:05)
You can see that when I switch to the TSVB where my interval is by 1d it starts the day at 6:00 pm and only shows that one that is at 18:05. I am expecting that the TSVB should use 00:00:00 to 23:59:59...Why is TSVB using 6 pm and how can I change that...

I have checked and Ubuntu is set to GMT America/Edmonton which is my timezone.


(Dallas Toth) #2

I wanted to add some more information to this. I created a Vertical Bar Visualization With my X-Axis as Date Histogram using Interval Daily and that visualization does work and show the count of 19 which is correct. This problem only exists in TSVB.

I have been using TSVB now to replace many of my Timelion visuals because of a different bug now to only fine that TSVB has a bug that causes the start of the day to not actually be the start of the day. Starting the day at 6:00pm has been found in every TSVB that I have as a Interval of 1d or 1w or 1M. When I use 1y it uses 5:00 pm.
1m and 1h are OK.


(Dallas Toth) #3

I have figured this issue out.
TSVB is hardcoded to use UTC for any thing in interval >= 1d regardless of the Advanced Settings > dateFormat:tz

Here is how you get around this issue.
Your dates for logstash inputs do not compensate dates for the UTC. Take the date as is and use that as though it is already UTC. Then Set your dateFormat:tz as UTC.

I wouldn't consider this a fix. The Fix would be that regardless of what dateFormat:tz is set to TSVB should always start at 12am for any interval >= 1d


(David Snider (Kibana Design)) #4

Pinging @simianhacker for visibility.


(Dallas Toth) #5

Any update on this issue?


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.