Unable to access Kibana with “License is not available.”

I have installed WorkplaceSearch.
I added the x-pack configuration to ElasticSearch by referring to the following URL.

Specifically, I have made the following statement.

$vi /etc/elasticsearch/elasticsearch.yml
xpack.security.enabled: true
xpack.security.authc.api_key.enabled: true
            order: 0

However, when I do so, I can no longer access Kibana, which has been working fine.
When I access Kibana from a browser, I get the following message.

statusCode 503
error "Service Unavailable"
message "License is not available."

Is there any configuration required to use Kibana and WorkplaceSearch together?

If you secure elasticsearch then you need to tell Kibana about it. Have a look at the Kibana guide.

1 Like

Thank you for your comment.
I see.
I put the username and password for elasticsearch in kibana.yml.

$ vi /etc/kibana/kibana.yml
elasticsearch.username: [MY_ELASTIC_USERNAME].
elasticsearch.passowrd: [MY_ELASTIC_PASSWORD].

However, when I access Kibana from a browser, I get the following error

An error occurred.
Sorry, the page you are looking for is currently unavailable.
Please try again later.

If you are the system administrator of this resource then you should check the error log for details.

What more settings do I need?

Have a look at the Kibana logs.

I'm moving your question to #elastic-stack:kibana

It seems to say `License is not available, authentication is not possible.

$ tail /var/log/kibana/kibana.log
... snip ...
{"type": "log","@timestamp": "2021-05-31T10:24:47+09:00", "tags":["error", "plugins", "security", "authentication"], "pid": "28000"," message": "License is not available, authentication is not possible."}
... snip ...

Do you have any other clues?

I see. I solved one problem.
It seems that the credentials I gave to Kibana were wrong.

You will need to set the following credentials, which can be obtained with the following command

$ ./bin/elasticsearch-setup-passwords auto

... snip ...

Changed password for user kibana_system

... snip ...

Changed password for user elastic
$ vi /etc/kibana/kibana.yml
elasticsearch.username: [MY_KIBANA_SYSTEM_USERNAME]
elasticsearch.passowrd: [MY_KIBANA_SYSTEM_PASSWORD]

$ systemctl restart kibana

You can now access Kibana from your browser.

However, the credentials that are required when accessing Kibana are elastic ones.


Why is this?

I'm posting this to prevent any unexpected closings.
Can someone please answer my last question?
I will close when this is resolved.

Is this just the way it is?
It doesn't make sense to me, and I'm still confused.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.