Unable to create Kibana index

Hi ,
I have ELK stack installed and imported the indexes , all these indexes are visible in Kibana under Saved object however I am unable to create new index .
More details about ELK stack
Elastic search - 7.1.0
Kibana - 7.1.0
OS environment - Linux
Sharing the screenshot for the reference .

Hi @DG13 , that message is saying there is no data in elasticsearch, can you check your es instance?

Thanks.

Index is created in elastic search and could see under elastic search index management .

But when I click on Kibana index management I could see this screen whereas when we install the kibana screen displays the create the index which is not getting shown my case .

What could be the issue ?

Thanks ,

Divya

Can you send me a screenshot of the indices you are seeing on the index management page or can you do :/_cat/indices/twi*?v&s=index&pretty ?

Can you also check that the sample data set works?

Imported indexes from my other ELK environment works and I could see it in kibana .
Steps I followed to export and import indices :

  1. Export the saved_objects to downloaded the json file from my local env ( hosted on windows )

2 . Imported these indices in kibana and it worked .

Thanks,

Divya

Hi,
I tried debugging and here is some of the findings -

  1. As you asked I tried adding the sample data to kibana index and I could see the index created at Kibana

GET /_cat/indices/sample?v&s=index

Output :
health status index uuid pri rep docs.count docs.deleted store.size pri.store.size
green open kibana_sample_data_flights FuV0cl1NRQ-McHTh1ocNgw 1 0 13059 0 6.4mb 6.4mb

  1. When I enable show system index I dont see system indices at Kibana :frowning:

However I could see the system indices at elastic search

What could be the root cause ?
Is it due to configuration mismatch or something else ?
Appreciate if you could help me proceed in right direction .

Thanks,
Divya

Finally able to find the root cause of the issue , posting it for the benefit of others .
Nginx which was used for routing purpose caused the issues , once removed the Nginx configuration and used the ELK stack only , All worked fine :slight_smile:
Thanks @LizaD for your help !!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.