Unable to generate plugin that works with any Kibana 7.7 releases

Hi guys, I've been having trouble generating Kibana plugins that work with Kibana versions 7.7.0/7.7.1.
Here are the steps I've used to generate my plugins:

  1. Clone the kibana github repo
  2. Run git checkout 7.7
  3. Run yarn kbn bootstrap
  4. Run node scripts/generate_plugin.js [my_plugin_name] (choose the correct version etc.)
  5. I copy the generated plugin and move it to the plugin folder of my Kibana version 7.7.0/7.7.1 (i've tried both)
  6. I then delete the optimize folder and run kibana using ./kibana in the bin folder.

These same steps have worked for me when I was working with kibana 7.6 versions. But for the 7.7 versions I get the following error when I start kibana in my browser:

What am I doing wrong? Is this an issue with what i'm doing or is it an issue with Kibana? If someone can run through these steps and let me know that would be great.

Instead of deleting optimize folder, have you tried running yarn kbn clean && yarn kbn bootstrap?

I've done that, when you generate plugins using the Kibana 7.7 branch from github, you get a plugin generated but this plugin is missing a package.json and index.js file

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.