Kibana 7.7 Generated Plugin causes kibana to fail

Hi guys,

I've been having issues with getting kibana to startup after installing my plugin. I generate the plugin using the kibana plugin generator. I went through all the steps on github and generated my plugin.

However when I install the plugin into kibana and try to start up kibana, i get the following error:

My kibana version is version 7.7.1, any idea of what i can do to fix this?

How are you running Kibana? If you are running from source, did you run kbn bootstrap and follow the instructions at

I did all that, when I generate the plugin it generates a plugin for me. I run into the issue when I take the generated plugin and install it into kibanas latest release of 7.7.1. It installs the plugin but when I try to access Kibana in my browser it gives me this error message.

When I previously generated plugins for version 7.6 I didn't face this problem.

You will have to generate a plugin from 7.7. Plugins are not compatible between minor versions of kibana.

Sorry I wasn't specific with my last statement, what I meant was that when I was running kibana 7.6 in the past, I generated plugins for my KIbana version with no issues.

I recently migrated over to Kibana 7.7.1 and I did generate a plugin from 7.7 following the same steps as I had done with the plugin generator when I was using 7.6. Here are the steps I followed:

  1. Using kibana's source on github I generated a plugin for version 7.7.1 (checked out branch 7.7, ran yarn kbn bootstrap, ran node scripts/generate_plugin [my plugin name] and generated a plugin for version 7.7.1.
  2. I grabbed the plugin I just generated from the /plugin folder of my kibana source. Then I installed it into kibana 7.7.1 which I downloaded from the elastic site.
  3. I ran Kibana 7.7.1 after installing the plugin, opened it up in my browser and was presented with the error from my first post.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.