Unable to view the data for the GET .kibana/visualization

(Ranganatha) #1

using kibana version 6.6.0
i tried
GET /.kibana/visualization/_search
and the ouput obtained:

{
"took" : 0,
"timed_out" : false,
"_shards" : {
"total" : 1,
"successful" : 1,
"skipped" : 0,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" :
}
}

but there are more than 10 visualization that i have created.but this data output is showing null.
am I doing it write??
was this working in the previous versions??

1 Like
#2

same error , is it due to kibana 6.6.0 ????

(Christian Dahlqvist) #3

What if you omit the type, e.g. GET /.kibana/_search ?

#4

Yes might work , but why is it not working with the type ?

(Christian Dahlqvist) #5

In Elasticsearch 6.x only a single type is allowed per index so I suspect type is no longer used to distinguish different types of entities (if it ever was).

1 Like
#6

Thanks , but will . /.kibana/index-pattern work to fetch index patterns ?

(Christian Dahlqvist) #7

Probably not. I suspect you would need to write a query and filter based on fields in the data.

#8

Then what to command to use to fetch index-patterns ?

(Christian Dahlqvist) #9

I am not familiar with the current format so would recommend you look at the structure of the data or wait for someone who is.

1 Like
(Ranganatha) #10

this worked for me,
GET .kibana/doc/_search?size=300

(Ranganatha) #11

GET index_pattern_name/_search

(system) closed #12

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.