Unknown setting [archived.xpack.monitoring.collection.enabled]

monitoring

#1

Hi,

We have installed ELK 6.2.1 using Docker.When we tried to disable the shards allocation using we are getting following erro.How can we resolve this..?

PUT _cluster/settings
{
"persistent": {
"cluster.routing.allocation.enable": "none"
}
}

{
"error": {
"root_cause": [
{
"type": "illegal_argument_exception",
"reason": "unknown setting [archived.xpack.monitoring.collection.enabled] please check that any required plugins are installed, or check the breaking changes documentation for removed settings"
}
],
"type": "illegal_argument_exception",
"reason": "unknown setting [archived.xpack.monitoring.collection.enabled] please check that any required plugins are installed, or check the breaking changes documentation for removed settings"
},
"status": 400
}


(Jen Huang) #2

Hello, can you paste the results of GET /_cluster/settings? The error is referring to a setting that is no longer supported, so it may need to be removed.


#3

Please find the response for

GET /_cluster/settings
{
"persistent": {
"archived": {
"xpack": {
"monitoring": {
"collection": {
"enabled": "true"
}
}
}
},
"search": {
"remote": {
"node name": {
"seeds": [
"xx.xx.xx.xx:9300"
]
},
"storagenodename": {
"skip_unavailable": "true",
"seeds": [
":50000"
]
}
}
}
},
"transient": {}
}

We tried to disable this setting like

PUT _cluster/settings
{
"persistent": {
"archived.xpack.monitoring.collection.enabled": "false"
}
}

but getting error like

{
"error": {
"root_cause": [
{
"type": "illegal_argument_exception",
"reason": "persistent setting [archived.xpack.monitoring.collection.enabled], not recognized"
}
],
"type": "illegal_argument_exception",
"reason": "persistent setting [archived.xpack.monitoring.collection.enabled], not recognized"
},
"status": 400
}


(Raji Sankaran) #4

I am facing the same issue with Elasticsearch 6.3 OSS docker image. Is there a fix or workaround for this?


(Raji Sankaran) #5

I installed Elasticsearch 6.3 with x-pack installed and still got the same error.

Workflow:

  • Start 3 Elasticsearch 6.3 (with x-pack) nodes as docker containers. Make them part of a 3-node cluster.

  • Start a 4th container and add it to the cluster

  • Try removing the 4th node using the curl command below.

       curl -XPUT "{masternode-ip}:9200/_cluster/settings" -H 'Content-Type: application/json' -d'
    {
     "transient" :{
        "cluster.routing.allocation.exclude._ip" : "{4th-node-ip}"
      }
    }'
    

The REST call fails with the following error

{"error":{"root_cause":[{"type":"remote_transport_exception","reason":"[es-node-1][172.18.0.2:9300][cluster:admin/settings/update]"}],"type":"illegal_argument_exception","reason":"unknown setting [archived.xpack.monitoring.collection.enabled] did you mean [xpack.monitoring.collection.enabled]?"},"status":400}

  • The get cluster settings provides the following response. I do not know what set the archived.xpack.monitoring.collection.enabled=true.

curl "10.76.144.18:9200/_cluster/settings?pretty"

{
  "persistent" : {
    "archived" : {
      "xpack" : {
        "monitoring" : {
          "collection" : {
            "enabled" : "true"
          }
        }
      }
    }
  },
  "transient" : { }
}

Any pointers to fixing this is highly appreciated!