Username/password prompt 8.3.0

I apologise if this is the wrong place (and a daft question) but I have a question regarding ElasticSearch 8.3.0 and user password.

In previous versions, once I have installed the ElasticSearch service ("elasticsearch-service install" and ingest attachment, I could then go to localhost:9200 and download/view the JSON file with no issues.

Since installing 8.3.0, I am getting prompted for a username/password. Has something changed now so a username/password is required? If so, what username/password is it looking for? Have I missed a step in the install?

Thank you for your time.

Hi @GrahamMarval Welcome to the community and thanks for try 8.3.0

YES Elasticsearch is secure by default now and so yes there is a password and the endpoints are secured via SSL with Self Signed Certs

There is / was a blog on this here

And here are the docs on it

when you installed on the console you would have seen something like this...

✅ Elasticsearch security features have been automatically configured!
✅ Authentication is enabled and cluster connections are encrypted.

ℹī¸  Password for the elastic user (reset with `bin/elasticsearch-reset-password -u elastic`):

ℹī¸  HTTP CA certificate SHA-256 fingerprint:

ℹī¸  Configure Kibana to use this cluster:
â€ĸ Run Kibana and click the configuration link in the terminal when Kibana starts.
â€ĸ Copy the following enrollment token and paste it into Kibana in your browser (valid for the next 30 minutes):
ℹī¸  Configure other nodes to join this cluster:
â€ĸ On this node:
  ⁃ Create an enrollment token with `bin/elasticsearch-create-enrollment-token -s node`.
  ⁃ Uncomment the setting at the end of config/elasticsearch.yml.
  ⁃ Restart Elasticsearch.
â€ĸ On other nodes:
  ⁃ Start Elasticsearch with `bin/elasticsearch --enrollment-token <token>`, using the enrollment token that you generated.

now your curl would look like

curl --cacert config/certs/http_ca.crt -u "elastic:password" https://localhost:9200

or if you want to ingnore the ca check

curl --insecure -u "elastic:password" https://localhost:9200

Hi @stephenb

Thank you for clarifying. I knew I'd missed something in the install lol

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.