V 8.5.0 update - boolean field not working in donut lens anymore

Dear All,

recently I updated to version 8.5.0
Since that time a donut lens isn't working.

This mapping for this donat is defined with

    "bq_DMZ": {
      "type": "boolean"

With logstash I am importing the data. In two independant pipelines there is a filter with

    mutate {
            add_field => { "bq_DMZ" => "true" }

The other pipeline sets this field to "false".
Using discover tool I can search for true or false and I get the results.
But using kibana to create a donat lens brings a strange error, when I move this field over to the "slice by" field. Unfortunatelly it's not possible to copy&paste the error.
As I said it worked fine before the update.

Any idea what could be the issue ?

// Hans

Running 8.5, I'm unable to reproduce this with a normal boolean type field. Is there anything special about this field? Can you take a screenshot of the error?

I hope it is readable. I just moved "bq_DMZ" from the left side to right field "Sliced by"

// Hans

@Stratoula_Kalafateli, I wonder if this is a migration issue? Do you know if anything has changed with Lens's handling of boolean fields?

Nothing that I am aware of. Can you save this visualization with the error on the library, then go to Stack Management --> Saved Objects and export this visualization and send it to us? Moreover from which version did you update? Thanx!

Dear All,

update was from the last 8.4 version as I do almost always an update when a new version is available. I think it was 8.4.3

Currently I am looking how to send/upload the export json file.

// Hans

{"attributes":{"description":"BindQuery: Location DMZ","state":{"adHocDataViews":{},"datasourceStates":{"indexpattern":{"layers":{"d2a5a381-f6d7-4e63-b960-d473cfd54184":{"columnOrder":["d33811d8-7802-49f3-bbf8-c3f1327041fa","0dbc81cd-e312-41a5-8949-172cdecff415"],"columns":{"0dbc81cd-e312-41a5-8949-172cdecff415":{"dataType":"number","isBucketed":false,"label":"Count of records","operationType":"count","params":{"emptyAsNull":true},"scale":"ratio","sourceField":"___records___"},"d33811d8-7802-49f3-bbf8-c3f1327041fa":{"dataType":"boolean","isBucketed":true,"label":"Top 5 values of bq_DMZ","operationType":"terms","params":{"missingBucket":false,"orderBy":{"columnId":"0dbc81cd-e312-41a5-8949-172cdecff415","type":"column"},"orderDirection":"desc","otherBucket":true,"parentFormat":{"id":"terms"},"size":5},"scale":"ordinal","sourceField":"bq_DMZ"}},"incompleteColumns":{}}}}},"filters":[],"internalReferences":[],"query":{"language":"kuery","query":""},"visualization":{"layers":[{"categoryDisplay":"default","layerId":"d2a5a381-f6d7-4e63-b960-d473cfd54184","layerType":"data","legendDisplay":"show","legendMaxLines":5,"metric":"0dbc81cd-e312-41a5-8949-172cdecff415","nestedLegend":false,"numberDisplay":"percent","primaryGroups":["d33811d8-7802-49f3-bbf8-c3f1327041fa"]}],"shape":"donut"}},"title":"BindQuery: Name Server Location","visualizationType":"lnsPie"},"coreMigrationVersion":"8.5.0","id":"ff2fea90-2474-11ed-9d10-7bff2f98235f","migrationVersion":{"lens":"8.5.0"},"references":[{"id":"67c7b160-2474-11ed-9d10-7bff2f98235f","name":"indexpattern-datasource-layer-d2a5a381-f6d7-4e63-b960-d473cfd54184","type":"index-pattern"}],"type":"lens","updated_at":"2022-11-26T12:44:26.058Z","version":"Wzk1NzAsMl0="}

Thanx! It seems that the bq_DMZ is a runtime field. Can you send me how you have configured this? To do so, go to the dataviews management page, select your dataview and click the pencil icon on the field. This will open a flyout, we want the set value script.

Many thanks for your reply.
Unfortunately I don't have a "set value" tab. This I have. I hope it helps.

If I remove "set format" then it works. But then I see only true or false.

// Hans

Interesting, so you have a field formatter. I can't replicate it to be honest. I added the same field formatter to a boolean field and I don't see the error.

The formatter is not applied (but this is a bug of 8.5 which will be fixed in 8.6 but I don't see an error)

I just upgraded to 8.5.2 but the situation is unchanged.
When I set "Set format" to "Static lookup" with key 0 and 1 and values then I get immediately an error. When I remove "Set format" then it's fine.
I can live with this situation. But definitely it worked with 8.4.something

Is this general the recommended way to view booleans as a text in kibana or do I try to do something unconventionally ?

// Hans

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.