When setting environment variable to `I18N_LOCALE: zh-CN`, Kibana's Security icon is broken

Assuming the following docker-compose.yml file, the kibana API key is generated by bin/elasticsearch-create-enrollment-token -s kibana.

version: "3.8"

services:
  elasticsearch-node01:
    image: elastic/elasticsearch:8.1.2
    environment:
      bootstrap.memory_lock: true
      ELASTIC_PASSWORD: "1234AF12-12CA-B2E0-BE8B-12345D5C123E"
      ES_JAVA_OPTS: "-Xms4g -Xmx4g"
    volumes:
      - elasticsearch-data01:/usr/share/elasticsearch/data
      - elasticsearch-config01:/usr/share/elasticsearch/config:rw
    ports:
      - "9200:9200"
      - "9300:9300"
    ulimits:
      memlock:
        soft: -1
        hard: -1
  kibana-node01:
    image: elastic/kibana:8.1.2
    ports:
      - "5601:5601"
    volumes:
      - kibana-data01:/usr/share/kibana/data
      - kibana-config01:/usr/share/kibana/config
volumes:
  elasticsearch-data01:
    driver: local
  elasticsearch-config01:
    driver: local
  kibana-data01:
    driver: local
  kibana-config01:
    driver: local
  • Start with docker compose up -d. Open Kibana normally, and the icon is normal at this time.
  • Then change docker-compose.yml as follows, add environment variable I18N_LOCALE: zh-CN, and docker compose up -d again.
version: "3.8"

services:
  elasticsearch-node01:
    image: elastic/elasticsearch:8.1.2
    environment:
      bootstrap.memory_lock: true
      ELASTIC_PASSWORD: "1234AF12-12CA-B2E0-BE8B-12345D5C123E"
      ES_JAVA_OPTS: "-Xms4g -Xmx4g"
    volumes:
      - elasticsearch-data01:/usr/share/elasticsearch/data
      - elasticsearch-config01:/usr/share/elasticsearch/config:rw
    ports:
      - "9200:9200"
      - "9300:9300"
    ulimits:
      memlock:
        soft: -1
        hard: -1
  kibana-node01:
    image: elastic/kibana:8.1.2
    ports:
      - "5601:5601"
    environment:
      I18N_LOCALE: zh-CN
    volumes:
      - kibana-data01:/usr/share/kibana/data
      - kibana-config01:/usr/share/kibana/config
volumes:
  elasticsearch-data01:
    driver: local
  elasticsearch-config01:
    driver: local
  kibana-data01:
    driver: local
  kibana-config01:
    driver: local
  • At this time, the Security icon of Kibana is damaged and cannot be viewed, which should not be normal behavior.

Hi @linghengqian ,

Hmm, yeah, that looks like a bug indeed, would you mind filing an issue at Issues · elastic/kibana · GitHub so that the relevant team can pick it up and fix?

Thanks!

Related issues continue to be tracked at When setting environment variable to `I18N_LOCALE: zh-CN`, Kibana’s Security icon is broken · Issue #129893 · elastic/kibana · GitHub .

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.