Why Interval in Visualization by Auto is per 0 milliseconds


(Sergey) #1

Hey guys,

We faced with issue that suddenly all our visualizations (line, bar chars) have X-axis (using Date histogram) split by Auto per milliseconds 0. Previously we use this Auto feature and since you change time period of visualization/dashboard it shows/changes to proper interval (if interval 7+ days, it shows split per day, or 3 hours which is very readable).
Once this feature is changed (don't know why), not after update of Kibana, by Auto always show Interval per 0 millisec.
So where it is possible to check settings to change this behavior?



(Thomas Neirynck) #2

@_Sergey

it seems Kibana is trying to do some form of auto-correction. when you see that warning message this interval creates too many buckets ...

It doesn't explain exactly why it shows by 0-milliseconds, but this is likely due to some rounding error.

If you open the spy-panel and look at the ES-request, what is the interval that the data is requested on?


(Sergey) #3

Hi Thomas,

As I checked it has next:

{
  "aggs": {
    "2": {
      "date_histogram": {
        "field": "@timestamp",
        "interval": "5s",
        "time_zone": "UTC",
        "min_doc_count": 1
      }

(Sergey) #4

Hey,
Just figure out what was the reason:

As we have prod and stag Kibana, I think to check advance settings in Index Patterns (as on Stag we don't have this issue with Auto interval 0 millisec).

So I find out that somebody changed this settings (it was a blank space before 1000):

Once I changed it (delete that blank space) and check our graphs - all back to normal. No Auto generates (depends on time period of check) readable intervals.