Why Metricbeat takes 2 minutes as an interval?

I set modules.period is 10s

metricbeat.modules:
  - module: logstash
    hosts: [ http://logstash:9600 ]
    xpack.enabled: true
    period: 10s
    enabled: true

But why is the interval of 2 minutes used as the abscissa?

I guess you're actually getting the right values as per your setting.

If you consider 20:30 and 20:32 time range, you can see 12 markings between them, i.e., 120sec/10=12.

It's only that your X-Axis is showing an 2 mins interval. If you set the x-axis to auto, based on your time rance, the X-Axis values change.

You can change this by editing the visualization in more settings.

If you consider 20:30 and 20:32 time range, you can see 12 markings between them, i.e., 120sec/10=12

yes, you're right.

If you set the x-axis to auto, based on your time rance, the X-Axis values change
You can change this by editing the visualization in more settings

Where are the two items you mentioned? I didn't find it in Stack Manager > Kibana > Advanced Settings > Visualization

No, you need to go to edit in the dashboard, click on the visualization you want to edit and you get the option to modify the visualization

Eg: Go to the Events Received Rate visualization and edit it, you can find X-axis settings.

In that you can modify it.

I added the following configuration in metricbeat.yml

setup.kibana.host: "kibana:5601"
setup.kibana.username: ${ELASTIC_USERNAME}
setup.kibana.password: ${ELASTIC_PASSWORD}
setup.dashboards.enabled: true

I found it created dozens of Visualizes and Dashboard, many of which were unnecessary


no visualization named Events Received Rate found.
BTW,Even if I delete all the above dashboards and visualizations, Stack Monitoring display is still normal

According to the official documentation Modules | Metricbeat Reference [8.6] | Elastic, Elasticsearch, Logstash, Beats, these Dashboard are not available

I found that the x-axis changes with the filter

1 minute

5 minute

15 minute

Yes you are right.

That's what I've mentioned in my previous statements.

It's only that your X-Axis is showing an 2 mins interval. If you set the x-axis to auto, based on your time rance, the X-Axis values change.

It will be default to Auto, and it changes with your time range.