Add filter in a dashboard proposes a wrong list of fields

When I try to add manually a filter in a dashboard (using add filter on top of the page), the list of available fields belongs to the default index and not on indexes used in the visualisations of the DB... (no viz is pointing on the default index).

Does anyone has any idea?
Thanks in advance

Hi @pchanas,

Can you provide more info about the issue you are facing (i.e.: what version are you using, the number of other indices used in your dashboard, the type of visualisations used: timelion, TSVB, Lens, Gauge, ...)?

I've just tried to create a dashboard on 7.10 with visualisations from 3 indices, and, when adding a filter, I am prompted to select which index to use:

If I have a dashboard with visualisations only from one index, the index selector is not shown and the list of fields is correctly shown based on that index:

Sorry, 7.6.2, no TSVB, no timelion, no Lens
We have pies, Gauges, Metrics, Bar charts, Vega and vizs created with extra plugins (transform and HTML).
Only 1 index is used in the dashboard.

After investigation, if you refresh the page (F5), the problem is "solved".
Closing Firefox, coming back to the DB, we have the pb, again after F5 it's ok :frowning:

1 Like

Oh! So it's a caching issue?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.