Cannot determine license type. Please check that you have the license plugin installed and configured in Elasticsearch with a valid license

reporting

(Vmcleitao) #1

Hi Everyone,

I would like to know if anyone gets the same error when tried to generate a report. Comparing with what it is explained in the online manual on https://www.elastic.co/downloads/reporting I have some diferences, firstly the license for 2.4.1 version is not available, so I got the following error

https://download.elastic.co/elasticsearch/release/org/elasticsearch/plugin/license/2.4.1/license-2.4.1.zip

NoSuchKeyThe specified key does not exist.elasticsearch/release/org/elasticsearch/plugin/license/2.4.1/license-2.4.1.zip80FD4C8D19E6DB5DFJW+U1B6o/EH5bgKMU/9YXtXvsZd1ZX0V+FcbZkrf3Nz088t/Z9YAUMrz1MXzE3Qo4a7RMPCeQI=

Based I tried to get the license for the version 2.4.0 and installed the Reporting latest version which means 2.4.1
but the result is something inconsistent like this.

It is possible that the constraint created was related with the difference on versions?

Sincerely,

VML

The license plugin is installed on /usr/share/elasticsearch and I see the botton to generate reports on Kibana.


(Joe Fleming) #2

There is no 2.4.1 version for the license, your use of 2.4.0 is correct.

Did you get that error by running bin/plugin install license as the download page has?


(system) #3